OctoPrint Fails Serial Connection To Pi 4B

What is the problem?

Failed Serial Connection Between Octopus v1.0 and Raspberry Pi 4B. Both are brand new devices. Tried via USB.

What did you already try to solve it?

OctoPrint with Klipper, OctoPi, Many different commands found online.

Have you tried running in safe mode?

Yes and still nothing.

Did running in safe mode solve the problem


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

Many Files and no idea how to add them here, sorry. This is my first time here asking for help.

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint -> 1.3.9
Printer -> Voron2.4
Firmware -> v0.11.0-307 (Klipper)
Octopus v1.0 -> Flashed with Klipper. Returned .CUR file
Octopus v1.0 does show up in /dev/serial/by-id(by-path) and it does say Klipper
Raspberry Pi OS -> Latest Release, but also tried with previous stable release and got the same results. So I do not think it has to do with which OS is running.

Yes, The Pi is self powered and Yes it is a sufficient (Official) Power Supply.
Yes, I've tried numerous USB cables to rule out a bad cable between the Pi and Octopus v1.0
Although just to be certain I did hook the Pi into a DROK Buck/Boost Converter to make sure it had enough Power.
Yes, I put a tiny piece of tape inside the USB to stop any Backflow or Drain of Power.
Yes, the Octopus does show up in lsusb
Tried to use KIAUH to install everything and still have problems. KIAUH even sees the MCU when asked to find it.
Yes, I turned off Serial Console and enabled Serial Hardware in raspi-config
Yes, I made sure it was not in /boot/cmdline.txt
Yes, enable_uart=1 is in /boot/config.txt
Yes, BT is disabled in /boot/config.txt & I even went as far as to uninstall the BT Stack

Plenty of other things were attempted, but here I am.........

Hello @Von_Woolfgard_Family !

You may consult the Klipper forum, because the serial connection between Pi and printer is shifted from OctoPrint/OctoPi to Klipper.

You have to pay attention for the correct communication port between OctoPrint and Klipper:


BTW: Never forget to attach the systeminfo bundle.

octoprint-systeminfo-20231031162017.zip (17.7 KB)

I followed everything, numerous times. As stated the MCU shows up everywhere, but fails in serial connection. As stated I didn't know how to upload the file. It was my first time here.
Yes, I am using the correct port. OctoPrint sees it (ttyACM0) perfectly fine and selects it perfectly fine.

Oh and if you see an "Undervoltage error" you can safely ignore that. I forgot to unplug a ssd when I ran the systeminfo bundle. I do not get this error at any other time. I was just transferring a printer.cfg file for my next test run.

OctoPrint should see /tmp/printer for the connection to Klipper.

The connection from the Pi to the printer is up to Klipper.

I strongly recommend to consult the Klipper forum. - Please do not forget the klippy.log over there. -

Well, I did what you suggested only to find out Klipper is working fine. I was instructed to try using Klipper with Mainsail and it works flawlessly indicating the problem at hand is within OctoPrint.

I'm at a loss as to what the problem could be, but I certainly do realize now why I want to use OctoPrint and not mainsail. While it works it is very lacking.

Can you please share a recent systeminfo bundel and the klippy.log

The last systembundle will be exactly the same as I have not even opened or started OctoPrint since your last request for it. I will include the Klippy.log though in my next message (I have to get it off the printer first).

As for your last systeminfo bundle, you try to connect OctoPrint to /dev/ttyACM0. That is the port of the printer.

You have to connect OctoPrint to Klipper via the port /tmp/printer.

Klipper itself has it's own mechanics to connect to the printer via the USB connection.

Now that I am home here is my klippy.log
klippy.log (41.8 KB)

Did you use a bare Pi OS? How did you get Klipper onto the OS?

Or did you use OctoPi with Klipper already installed?

As for the klippy.log:

This is a run with Mainsail/Moonraker:

webhooks client 547730701968: Client info {'program': 'Moonraker', 'version': 'v0.8.0-190-ge03dbe3'}

Not with OctoPrint.

Tried numerous ways to get this running.

Finally able after much digging. For whatever reason it did not want to work well with the latest release of Raspberry Pi OS (Bookworm).

I got fed up of Mainsail working and OctoPrint not working so I stripped the Pi bare and started over.

This time I use the previous version of Raspberry Pi OS and used KIAUH again to install everything and this time it finally worked. So somewhere, somehow OctoPrint seems to have an issue with the newest Raspberry Pi OS. I don't know what else it could be since Mainsail worked basically right out of the box: as they say.

Either way I am now happy everything is working as expected.

Asides from the first Clog; that is. HAHAHA

There appears to be some "missing" detail here. First, there is no mention of how OctoPrint was installed on each of the Raspberry Pi OS images. OctoPi 1.0.0 is based on Debian Bullseye but BookWorm is mentioned. I believe it would be useful to provide links to the actual images used for the OS and links to what scripts were used to install OctoPrint and Klipper.

Mainsail is also mentioned but again, no details (i.e. what version / image etc.).

@Von_Woolfgard_Family, I know you have it working now but adding these details may help the next person that finds this topic.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.