Octoprint finds the snapshot but not the stream

Logitech C170
What is the problem?
mjpegstream works just fine on its own, when I launch it using the script webcam start (described here)I can access both snapshot and streams at my_ip:8090/action=stream/snapshot. However, in Octoprint, specifying the snapshot adress http://127.0.0.1:8090/?action=snapshot works fine, but setting the Stream URL to /webcam/?action=stream as recommended doesn't. Of course setting a full http adress like the snapshot one doesn't work either. When trying to access my_ip:5000/webcam/?action=stream I get a 404 error.
What did you already try to solve it?
Note that I changed the binding port to 8090 as I have another service running already on 8080. Shutting this service down and running the webcam stream on 8080 doesn't change anything to the problem. I didn't see anything like this on the forum.
Logs
I haven't enabled the webcam as a service so I don't have any service logs.

2020-06-10 08:09:37,690 - tornado.access - WARNING - 404 GET /webcam/?action=stream&1591772977119 (192.168.1.49) 45.14ms
2020-06-10 08:11:13,854 - tornado.access - WARNING - 404 GET /webcam/?action=stream&1591773073181 (192.168.1.49) 38.76ms
2020-06-10 08:14:21,275 - tornado.access - WARNING - 404 GET /webcam/?action=stream&1591773260656 (192.168.1.49) 36.12ms
2020-06-10 08:14:32,794 - octoprint.server.util.sockjs - INFO - Client connection closed: 192.168.1.49
2020-06-10 08:14:32,864 - tornado.access - WARNING - 404 GET /webcam/?action=stream (192.168.1.49) 36.20ms
2020-06-10 08:14:57,537 - octoprint.server.util.sockjs - INFO - New connection from client: 192.168.1.49

Additional information about your setup (OctoPrint version, OctoPi version, ...)
Octoprint 1.4.0 installed on Raspbian 4.19 on a Raspberry pi 2

Nevermind, I figured out that I forgot to set the reverse proxy for the path /webcam/ to work. I set it up using nginx and now it works.

1 Like