Octoprint from rpi3b+ to rpi3a+

#1

What is the problem?
I've got a rpi3b+ running octoprint. Been running great for months. Got an rpi3a+ and swapped the SD card into it but no luck. Won't connect to internet at all. Any ideas?
What did you already try to solve it?
Opened the wlan config file and made sure ssid and Pw were correct and reinserted card into old b+ and everything worked fine.
Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

#2

What operating system are you running ?

Is it an Octoprint image that you downloaded and burned to an SD Card, or are you running something like Ubuntu or Raspbian, and then you installed Octoprint ?

#3

Hi Glenn,

I did basically the same and it worked for me without problems. Have you tried a "normal" Raspbian image with the A+? Just to make sure you don't have a hardware problem with WiFi on the A+.

#4

Okay, so here's what probably happened.

  1. "Been running great for months..." means that you imaged your 3B+ with an OctoPi which was post-June2018 but perhaps not quite Nov2018 of the underlying Raspbian. Or maybe you had the June2018 and you did a sudo apt-get update && sudo apt-get upgrade sometime before Nov2018. The footer for your OctoPrint would indicate that you have perhaps 0.15.1 for OctoPi.
  2. You then move the microSD over to the 3A+. The red LED comes on but there's no green activity light, as if it is bricked.

Fix version 1:

Buy another microSD card, image it with latest OctoPi 0.16.0 image and life will be sweet. This will work in either computer.

Fix version 2:

Put the microSD back into a 3B+ or 3B computer, run sudo apt-get update && sudo apt-get upgrade and let that finish. Then sudo poweroff, do the microSD swap and see if that's now happy.

Caveat

Why would you want to downgrade the RAM from the 1GB in the 3B+ to the 512MB in the 3A+?

Suggestion

If you're running this headless, then go into config.txt and set gpu_mem=64.

#5

You are correct it was an old version and I just hadn't updated. Ended up etching a newer image the card and all is well. Also I'm. Downgrading because the pi 3 b+ is over kill for what I use it for. I'm running headless with no webcam so I'm not using anywhere near what the b+ has to offer, the a+ is perfect for me and gives me back a b+ for other projects!