Octoprint getting stuck booting at rainbow screen

What is the problem?

I have a RPI2b that has been running octoprint flawlessly for a couple of years (I'm just a hobbiest so only use it sporadically throughout each year). I noticed the last couple of time I switched it on it would fail to boot past the rainbow screen, powering off and on once or twice would usually solve this issue until today when it persists to stay on the rainbow screen. Can someone point me towards the first steps of resolving this problem?

What did you already try to solve it?

  • I have the official RPI usb adaptor and I've also tried another official adaptor to rule out problem power issues
  • Made a new RPI OS image on a different card and successfully booted to the setup screen
  • Put the SD card into a linux system to check both the boot and octoprint partitions are visible

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


Is that the usual way you shutdown the Pi: Just power off?

That's all I could do on the rainbow screen

I meant before you got into that state.

more than likely corrupted/failed SD card. flash octopi fresh and put it in and see if it comes on. if it does then you might be able to use that linux system and retrieve your settings from /home/pi/.octoprint.

how did you shut it down in the past? just power it off? if so, that can and will eventually kill an SD card.

So if I copy the contents of this folder to the new image I've created, things should be back to the way they were?

not exactly. That will get all your settings and files, but the actual plugins themselves will need to be manually installed back.

I think I only had 2-3 plugins installed previously, is there a file or folder that I can locate to find out which ones I had installed.

if you look in /home/pi/.octoprint/config.yaml it will at least show you which plugins were installed that had settings modified/saved from default.

if you look at a octoprint.log file from the logs folder and has an OctoPrint startup listed it will also have the plugin list in there.

Thanks for the help all, was finally able to get things back together. Lesson learned, backup of working card made and no more rude shut downs

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.