Octoprint goes offline very often

Octoprint goes offline often--- sometimes during print

What I have done :
Raspberry Pi3B
New SD Card
Fresh new Software install
New 3A Power Supply
Removed PI from case
Hard Wired
Firmware 1.8.6
CR10 Smart Pro
I have another unit with same exact specs running same firmware, same cables, same plugins, Etc

This has been going on for over a month and I am not sure what the issue is.

I am not privy on how to read the logs. sorry

octoprint.log (114.3 KB)

I have not tried SafeMode Yet

I don't see in your log where you tried running in safe mode?

There is this error, which is from your printer. Might want to check your thermistor connections and make sure you don't have a short a loose connection.

2023-01-12 01:21:50,921 - octoprint.util.comm - WARNING - Received an error from the printer's firmware: MINTEMP triggered, system stopped! Heater_ID: 0 - Printer halted. kill() called!

1 Like

As @jneilliii says, the thermistor is going open circuit, so the thermal protection in the firmware is kicking in and shutting down the printer. Unplug the thermistor from the control board, connect to a multimeter and waggle all the cables as far as the hot end. If you've had a problem on the hot end recently its quite possible the wires or PTFE insulation tubes at the thermistor somewhere near the clamp screw are damaged so its shorting, or broken, intermittently.

Also PTFE has an upper temperature limit beyond which it starts degrading and emitting dangerous fumes, so if you have been running at Hot End temperatures over 250degC that might have damaged the insulation.

Hopefully you can find an OEM thermistor which matches the connectors and the wires are long enough. Most easily available replacements have the wrong connector and are too short, so you'll have to splice them and heatshrink the joins.

If you do replace the thermistor, be sure to run a PID tune, several times, to make sure you blow the right settings into the EEPROM.

Will this error, in mini temp, cause Octoprint to go offline?

I have had an issue with the ribbon cable and have a new one here to replace. I had to solder the wires due to crease in the ribbon cable. I will be replacing the cable this weekend. BUT I believe this error was me pulling the connector off while it was heated, to check the connections.

I have thought that maybe the PI was overheating and added a fan.. Was my last option to try.. Never hurts.

I have see nan Overheating on another report. As well as under-voltage which prompted me to change power supplies

Any firmware error will by default cause OctoPrint to disconnect.

1 Like

IT goes offline while idle now -- just had this issue tonight

Which narrows it down to the USB cable or the power to the mainboard dropping.. i.e, there's not enough voltage to run the mainboard, or the mainboard, the SMPS in Creality printers really don't like voltage dips.

Check also the connections from the printer PSU to the mainboard, is there an XT60 connector between the SMPS and the mainboard as on an Ender3?.

could be backpowering related issues if you haven't mitigated that.

Good point, backpowering thru the USB port, always a good idea to use an isolating adapter or tape over the +5V. I do this regardless of printer make/model.

ok team... I am back to this--- I just would periodically reboot it to get through.. I have 2 other units that do not exhibit this behavior - attached logs
Need help identifying the reasoning for the offline.

Replaced cables
Replaced Pi
Replaced Card
Same behavior
octoprint.log (110.4 KB)

did you ever try safe mode?

Where is the power for the Pi coming from?
Do you get the Undervoltage icon on the top menu bar, looks like a lightning bolt and an exclamation mark? Although your attached logs suggest not - I searched for throttle BTW.

When you reboot, can you ssh onto the Pi's CLI, then leave it connected whilst you print?, if the session drops, that's a clue there's a power problem, which may affect the controller board in the printer - I have an Ender3 Pro which does this occasionally, but its connected to a UPS, the Meanwell SMPS seems more of a problem than the stock Ender3 SMPS, but I don't have a voltage monitor attached to the feed.

Yes, Even In safe mode it disconnects.

I changed to larger PS and do not see an under-voltage issue or throttling of any kind..
I run from MAC and SSH is a blur for me--- I have a Windows Laptop with Putty but need to remember how to SSH into the PI.

Its offline once a day at least now---

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.