OctoPrint goes to sleep after upgrade to 1.8.2

What is the problem?

My Raspberry Pis running OctoPrint go to sleep after inactivity, and I need to reset the pi to get it running again. This problem is only occuring since I upgraded to 1.8.2. Before, I never had this problem. I was running 1.8.1 before. I have three units, one 3B, one Zero W, and one Zero 2 W.

Sometimes, after a lot of trying, I get to connect to them again without restarting them.

What did you already try to solve it?

I did a lot of Google searching, but haven't found anything relevant.

Have you tried running in safe mode?

Yes.

Did running in safe mode solve the problem?

No difference.

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

Prusa MK3S+ w/ Zero 2 W running 1.8.2
octoprint-systeminfo-20220817140603.zip (1.3 MB)

There is no dedicated 'sleep' function that I know of. What's the behaviour you are seeing? Does it become unreachable? Drop off the network connection?

I also have this problem after upgrading. My raspberry goes to sleep. The problem is that I cant cancel the print, everything goes off line. The only way to get out of it is to shut off my Prusa printer, kill power to the PI and then restart a completely new instance of octoprint.

There was a security issue which is why I upgraded. Whatever the update did to fix the security issue broke something. The connection is completely broken, I cant upload files also after it goes offline/standby and it gives me an error.

Only way to fix, restart printer, PI and restart the Browser to Octo

Anyone experiencing this?

This is still the first I have heard of it 'going to sleep'. Please elaborate on what you call 'sleep', because I don't know what this is.

I think you probably have an issue with the wifi/network connection to your Raspberry Pi, especially if the print continues while OctoPrint is inaccessible. Try it with an ethernet cable to see if that stops it dropping out. Check if it is still connected to your network. Raspberry Pi's WiFi disconnecting is not a new problem and there are many many posts about this on this forum and others.

Hello,

My Wifi Router 5G (Moca Extended) from Fios is about 12 feet away from the Raspberry PI. I have 1 Gigabit in the house, and I am an IT project Manager. This all started when I upgraded to the latest version (because of security concerns), as the original poster did as well.

Sleep= The cancel and pause command in browser will stop working. I cannot get back into octoprint UI even when doing a refresh with the browser refresh. I can no longer log in from another computer into the Octoprint UI at the same time as I did in the past. Obico is acting up and no longer functioning properly.

The print will start correctly. I can try to get a connection via the CONNECT button in the UI and it will not be able to connect. The print can finish sometimes, but I wont be able to print anything, I wont be able to upload anything (fails), and the only way to connect again is to power down the Raspberry Pi and the Prusa MIni printer.

Nothing network wise changed, nothing else changed. The only thing that changed was that I updated the firmware on the Octoprint because of "security issues" -- Wouldnt you agree two people from different places with the same issue is not a coincidence after updating the software?

I had this running for well over a year with no issues.

1 Like

Thank you @MAX12345 for telling your story.

@Charlie_Powell I can provide more details on the 'sleeping'.

  1. I turn on the Raspberry Pi. Within a minute or so, it boots up, and I can see the OctoPrint UI in my browser. Also if I scan the local network with Fing, I see the octopi instance.
  2. I wait for let's say 30 minutes. (I never measured how much wait time I need exactly, I could do that.)
  3. I try to load the OctoPrint UI in the browser, and it would not load. I try to look at the devices on my local network using Fing, and the Raspberry does not show up, or at least does not show up as an octopi instance. I try to ping it and it does not respond.
  4. Sometimes if I mess with it enough, it can get it to come up again. I haven't managed to find a reliable method to do so. I noticed that once I restarted one of the raspberries, and two of them came online after that... weird.

I never had an issue with the prints interrupting, so I assume the problem is only with the WiFi / network. I shall try with wired connection to see if it is the WiFi.

Altogether I agree that this sure looks like a network / WiFi / Rapsberry issue. However, the facts that

  • it came up right after the upgrade to 1.8.2
  • it worked rock solid for many month before
  • it came up the same way the same time on 3 different raspberry pi models
  • it also happened to @MAX12345
    makes me think the upgrade is a key element of the puzzle here.

There are some routers that close down WiFi connections after a certain time of inactivity.
You may check your router settings.

Why would that happen now, and not before?

That said, you might be right. I was playing with it this morning, and learned some things:

  1. One of the pis is actually still running 1.8.1 - I forgot to upgrade it, and it still has this inactivity issue!
  2. I was able to bring them back online by pinging for a long time. It took 86 tries. What could cause this?

Sometimes routers draw updates during the night.

You may check the router settings just in case.

And that proves to you what I was about to tell you: this has nothing to do with the OctoPrint update and everything with your local network hardware.

An update to OctoPrint is simply incapable of interfering with whether your Pi is reachable on your network or not. An update of OctoPi might, but those don't come over the air but require you to flash a new image to the card.

1 Like

Actually Octoprint is closing all the ethernet ports a few minutes after a print finishes. It doesn't go to sleep it just becomes inaccessible. I did an update to Linux and the problem went away.

Then it wasn't OctoPrint, it was the OS

Hello,

I just looked at my PI and realized it is NOT on WIFI. It is going to a dedicated switch with Ethernet.

Your assumption is right, it did not write to the Octoprint. But OctoPi Local itself is having problems get back into the Octoprint Raspberry Pi. What was the security issue, and how was it fixed?

Also, I noticed I wont be able to connect and then I hit refresh a few seconds later and it connects. Why is this?

So now, you have people who are on Wifi and Direct Ethernet with this issue. Nothing changed except the most recent security update. This rules out Wifi Completely.

If you really think it was the upgrade to 1.8.2, either roll back a version or study the code yourself:

I have managed to resolve my problem. I assigned a permanent IP to each Pi on the local network, and they work perfectly ever since.

It was probably a coincidence that I run into this issue at the same time as I upgraded to 1.8.2.

Thank you everyone for the feedback and to push me to think about the network instead of the software update.

2 Likes

I still have this problem. I have changed browsers. But I have a work around to get back in.

After a print, it goes dead. Cannot upload or print again.

My baudrate is 250k
Printer profile Default.

No refresh, or going through another browser will work

If I change the Baudrate toi AUTO, and hit refresh, it will log me in.

Once it is logged in, the baudrate goes back to 250k

???

I also want to add, when I hit print. It will print.
But the status state stays in operation
All the info under resend ratio 0/7 etc, temp, etc, print time, all go dead while it is printing.

I can also continue to watch my print from my PI camera through the control tab... (live)

It seems that you have a different issue to the original poster - they had a complete loss of connection to the server, which was a network issue and in the end not related to the 1.8.2 upgrade. It might be easier for you so start your own post, so we get the full information about your setup, along with testing it in safe mode and providing the systeminfo bundle.

1 Like