Octoprint goes to sleep ? power management is turned off


#1

What is the problem?

After installing octoprint on my raspi 3 it works fine for couple of hours, but eventually wifi will disconnect and device seems to go to sleep as connecting keyboard and monitor does not wake it up. I just get a black screen.

I found it could be related to power management issue so i made sure that option is turned off.

What did you already try to solve it?

I have installed latest version of raspbian from raspberry pi website just to test if it will drop connection, it does not so i assume theres an issue somewhere in octopi's configuration.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

Im using latest octoprint from download section, after setup i update octoprint to 1.3.6 as it asks for it.
Using onboard wifi, i do have wifi dongle but thats another can of worms to be sorted later.


#2

period regardless of the power saving settings.
This turns out to be due to dpms.

xset -dpms

turns it off, but only for one session. I keep meaning to put that in the
startup scripts.

Now, this isn't on a Pi, and it doesn't sound exactly like your issue, but
it might be worth looking at.
More info: https://www.raspberrypi.org/forums/viewtopic.php?t=18200


#4

Umm... that command isnt recognized by octoprint. I dont even think xset is installed ?

I have possibly found a fix, octoprint has been idle for couple of hours now and it did not disconnect from wifi.

sudo nano /etc/kbd/config

Edit these 2 lines :

BLANK_TIME=0 (Set to 0)

POWERDOWN_TIME=0 (Set to 0)

Now just reboot device.

sudo reboot