Octoprint ignores Z-Offset after Firmware update to Marlin 2.0.9_DW7.4.3 TM3D

What is the problem?

The issue I am having is that since I updated the Firmware of my CR-10 MAX, Octoprint is ignoring my z-offset no mater what. This results in uselessness of my BL-Touch which is quite important for a big bed like the CR-10Max.

What did you already try to solve it?

I've tried setting up the z-offset through the terminal, or through the screen with the new tiny machine menu which seams to work great but not communicate with octoprint. I can control the printer with both the screen and octoprint but it only prints properly with the right z-offset when leaving octoprint out of the game.

Have you tried running in safe mode?

No I haven't.

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:99.0) Gecko/20100101 Firefox/99.0
connectivity.connection_ok: true
connectivity.enabled: true
connectivity.online: true
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1500
env.hardware.ram: 1903988736
env.os.bits: 32
env.os.id: linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 4 Model B Rev 1.4
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 20.3.3
env.python.version: 3.7.3
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.7.2
printer.firmware: Marlin 2.0.9_DW7.4.3 TM3D 5SMDBB (Oct 18 2021 16:27:08)
systeminfo.generator: systemapi

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

I have read through many forum entries trying to figure this out but I not having any success. I'm suspecting that the tiny machines firmware handles the z-offset storage differently then the original creality firmware. Does anyone have experience with that?

Please I need some help!

thx in advance!

The z-offset should be stored in the firmware EEPROM. If you change it, you may need to save it with an M500. You can check the current value with M851 (and set it with M851 Zxx.xx).

OctoPrint doesn't have any knowledge of or change the z-offset value but it may cause the printer to reload saved settings.

Thx for your quick reply @b-morgan !

I had forgotten to mention, that I was using the z-offset plugin. And before the firmware update I was able to adjust the z-offset mid print. Which is not possible anymore.

For some reason it is something that needs be be done before homing. Now that I have set it before it seams to work just fine.

I will do some further testing in the next days but it is looking promising.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.