Octoprint image with bullseye

What is the problem?

Installation on bullseye

What did you already try to solve it?

I did it with buster

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


Is there an image of Octoprint with bullseye OS ?
I have an octoprint running on buster and I would like to upgrade it on bullseye.
So, I have reinstalled it using Raspberry PI Imager. But the OS is still buster.
So, could you help pto install the last release of Octoprint on bullseye ?
Thank in advance

If you don't have a need to upgrade your OS to Bullseye (and don't know how to), I wouldn't recommend just trying to do it for the sake of it. The latest stable OctoPi version is 0.18, which is based on Buster.

You can of course install an RPi OS Bullseye image and install OctoPrint yourself using the guide linked on the download page.

If you would like to get involved in testing a new OctoPi image (which is Bullseye-based), you can do that too although you must be prepared to come across potential bugs - there's a reason it is not a stable release yet.

Thanks for your answer.
I haven't a real need to upgrade to bullseye except buster will be no more support very soon.
So, I am really surprised Octoprint is still running on buster

There were quite a few changes that broke compatibility with the move to bullseye (throwing out the old video hardware encoder was quite painful), as well as supporting the 64 bit builds & new 'userless' first-boot system from the Raspberry Pi foundation made it a pain. You can see the work that is ongoing to try and get the image stable, it has taken a while.

Ok, so, wait and see.

It got longtime support until 2024-06-30

Sure of that ?
I thought it was 2022.

I hear what you say.
But I have a camera: ArduCam 16 MP autofocus that I would like to get working. Presently it is not being recognised to create the 2 video devices. I'm clutching at straws, but there is a possibility its only supported on Raspbian 11. At least thats what its documentation says. And certain of the builds required fail during compilation, and some of the shell scripts too.
The camera documentation indicates its easy to get working. so, misleading, to that extent, like a lot of things....

BUT: The strongest possibility is that the camera hardware is cactus, and so I have emailed the supplier to try them out for a replacement, but meanwhile this pathway to upgrade the OS seems plausible. I could also try out your RC2 of Octoprint, selecting the 64 bit version, and see if it works (or at least, mostly works).

sry I missed your question

Yes I'm sure :slight_smile:
Bildschirmfoto vom 2022-10-01 09-55-29

Try this guide (but use the latest nightly from the pi imager instead)

OK, I will try that out. Key seems to be to use the nightly build of bullseye.

When the camera is working, then I can install Octoprint the manual way.

But I am still unsure if the camera itself is working, because its not seen on the i2c bus (via i2cdetect).
I have pressed the reseller for a replacement.

Cheers and TKU.

I mean the nightly build of OctoPi. It comes with OctoPrint.

I should learn to read EVERYTHING in the posts (lol). Looks like another one to build...

OK, I did as you suggested. Eg. downloaded the nightly build file, and made a boot image on the SDcard.
It installed OK.
I completed step 1 thru 3 without any problems. and the dev/video0 and video1 devices are now created.
There was an error when I attempted to create a test image still shot.

But at Step 4 is where problems begin:

[ 51%] Built target input_uvc

make[3]: Entering directory '/home/pi/mjpg-streamer-libcamera/mjpg-streamer-experimental/_build'

Scanning dependencies of target input_libcamera

make[3]: Leaving directory '/home/pi/mjpg-streamer-libcamera/mjpg-streamer-experimental/_build'

make[3]: Entering directory '/home/pi/mjpg-streamer-libcamera/mjpg-streamer-experimental/_build'

[ 55%] Building CXX object plugins/input_libcamera/CMakeFiles/input_libcamera.dir/input_libcamera.cpp.o

In file included from /home/pi/mjpg-streamer-libcamera/mjpg-streamer-experimental/plugins/input_libcamera/LibCamera.h:20,

from /home/pi/mjpg-streamer-libcamera/mjpg-streamer-experimental/plugins/input_libcamera/input_libcamera.cpp:31:

/usr/include/libcamera/libcamera/controls.h: In instantiation of β€˜void libcamera::ControlList::set(const libcamera::Control&, const std::initializer_list<_Up>&) [with T = libcamera::Span<const long long int, 2>; V = long long int]’:

/home/pi/mjpg-streamer-libcamera/mjpg-streamer-experimental/plugins/input_libcamera/input_libcamera.cpp:259:77: required from here

/usr/include/libcamera/libcamera/controls.h:403:14: error: no matching function for call to β€˜libcamera::ControlValue::set<libcamera::Span<const long long int, 2> >(libcamera::Span<const long long int, 4294967295>)’

403 | val->set(Span<const typename std::remove_cv_t>{ value.begin(), value.size() });

| ~^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

/usr/include/libcamera/libcamera/controls.h:178:7: note: candidate: β€˜template<class T, typename std::enable_if<((! libcamera::details::is_span::value) && (! std::is_same<std::__cxx11::basic_string, typename std::remove_cv< >::type>::value)), std::nullptr_t>::type > void libcamera::ControlValue::set(const T&)’

178 | void set(const T &value)

| ^~~

/usr/include/libcamera/libcamera/controls.h:178:7: note: template argument deduction/substitution failed:

/usr/include/libcamera/libcamera/controls.h:177:30: error: no type named β€˜type’ in β€˜struct std::enable_if<false, std::nullptr_t>’

177 | std::nullptr_t> = nullptr>

| ^~~~~~~

/usr/include/libcamera/libcamera/controls.h:190:7: note: candidate: β€˜template<class T, typename std::enable_if<(libcamera::details::is_span::value || std::is_same<std::__cxx11::basic_string, typename std::remove_cv< >::type>::value), std::nullptr_t>::type > void libcamera::ControlValue::set(const T&)’

190 | void set(const T &value)

| ^~~

/usr/include/libcamera/libcamera/controls.h:190:7: note: template argument deduction/substitution failed:

/usr/include/libcamera/libcamera/controls.h:403:14: note: cannot convert β€˜libcamera::Span<const long long int, 4294967295>((& value)->std::initializer_list::begin(), (& value)->std::initializer_list::size())’ (type β€˜libcamera::Span<const long long int, 4294967295>’) to type β€˜const libcamera::Span<const long long int, 2>&’

403 | val->set(Span<const typename std::remove_cv_t>{ value.begin(), value.size() });

| ~^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

So, this is a different issue than I found when I tried this earlier. But to the same effect: libcamera not successfully built. Lines following the quoted text told me various Error 1 and Error 2

I am checking over my work to see if I missed any steps.

Ok the above issues during compilation would be unrelated to the physical device whether working or not working. But the prior step 3 indicates the physical device may be having problems.

I got to hope that the development team are continuing to work on mpjeg-streamer-libcamera because it can only be a programming issue. The compiler is agnostic about the hardware environment.

I have to say When I bought this camera I didn’t think it was this close to bleeding edge. Since it’s been out for awhile. I am wondering what gods I offended.

Kicking myself for not reading here first and not backing up my SD. Can anyone help me recover from this? I upgraded to Bullseye and am getting the Welcome to nginx screen. I'm not opposed to starting over but would like to at least recover my old Octoprint setup files. Please help. Thx

Anyone have an update on getting OctoPrint working on Bullseye? I bougth this 7" ElecLab RPi Touchscreen from Amazon and can't get it to work on OctoPi SSD past bootup unless I set HDMI Safe Made to Yes ... thinking it needs Bullseye ... any ideas? :slight_smile:

You have always been able to install OctoPrint on a bullseye system (i.e. stock RPi OS), and the manual install guide will let you do that.

There is also an OctoPi release candidate that runs bullseye, which you can find in the RPi imager or on the download page.

gotcha, thanks .. think it's best just to go into octoprint web page, do a backup, reimage and follow that guide then restore?

That would be what I would do