Octoprint in Windows 10

What is the problem?

Can't start Octoprint in Windows 10

What did you already try to solve it?


Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


need more information, ie how did you install?

1 Like

Hello @Shopgeezer !

We may summit all supporters and make wild guesses what it could be.

Honestly: You just tell us you want to run OctoPrint on WIn10. A bit more information would be really helpful:

  • How did you install OctoPrint on the PC: Script, manual, or something else
  • If one of the above: What exactly
  • How did you try to start OctoPrint?
1 Like

Hi. I started this topic, gave it a title and filled in what it was about. When I tried to proceed down to the section where you fill out all the details of the installation and Windows settings I could not type anything. Each section had "Write Here" below the heading but the area where I was supposed to write would not allow the entry of any text. It was just white space. This was in Windows 10 using Edge. I have had problems like this before. I am now in Chrome and things seem to be working ok.

I used the experimental install program to install Octoprint directly to my laptop. This was some months ago. It worked great. No problems at all. The install program did everything, installed Python, set up all the complicated bits, it all went very well. I printed an entire RC airplane with Octoprint. This solved my problem in that the SSD card reader in my CR20 printer broke and printing USB out of Cura is very undependable. Octoprint was rock solid!

Fast forward to today. I tried to fire up Octoprint to start another project and realized to my chagrin that I couldn't remember how to start the program. All the information that I can find online only relates to the Raspberry Pi installations. Typing "Octoprint:5000" and "localhost:5000" and everything else I could find into the address bar in the browser did not start the web interface. I feel somewhat stupid, but memory dims after awhile. I know that it is a simple entry in the address bar of the browser but it seems that the direct to Windows install is a bit rare. Anybody out there using it? How do I start Octoprint in the web browser?


If it was my installer than it adds services to Windows (if you enabled that option during install). If you open services manager from the start menu you should see OctoPrint on Port 5000 listed in there and be able to start it from there.

EDIT: the installer also adds a shortcut to Service Control folder, which has sub-folders based on port used.

Been gone for awhile. Thanks for the reply. The Octoprint Service is running. How do I get the web interface up in Chrome? Typing 'Octoprint:5000" in the address bar does not do anything.

Try with:


on that Windows PC

Yes that did it. Thanks a bunch. Now for the struggle to recognize the printer. It gets there eventually. Thanks again.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.