Octoprint increasing X,Y size of my print

What is the problem?

When I look at "model size", Octoprint will increase X,Y of my print. The X is always around 170mm with Y at 180mm.

What did you already try to solve it?

Tried Cura and Creality slicer. Tried installing Octoprint in 3 different Pi (3, 3B, 400). Tried to actually print in case it is not displaying correctly - print came out LARGE. Tried all 3 Pi not plugged into printer. Ender 3 Max Neo has that USB power problem so I thought that may have done something - nope. Tried Onshape (self created) as well as different models from Thingiverse. Have not added any plugins but did SafeMode with all 3 just in case, no luck. EX: 131KB file (small) has Model Size: 186.9mm x 180mm x 8.12mm. It's actual size is 52mm x 5mm x 8mm. Have gone through all the settings, just case I missed something, but not seeing what I could have missed.

Have you tried running in safe mode?

Yes.

Did running in safe mode solve the problem?

No.

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

WRITE HERE

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint V1.8.6
Windows 11.
Edge browser.
Ender 3 Max Neo - did not update firmware. No problems printing directly from card.

octoprint-systeminfo-20221224175740.zip (186.1 KB)

Attached system
Missed that in my original

I've never heard of this happening before. Can you download the gcode from octoprint and compare that file with one exported directly from your slicer? OctoPrint just sends the commands found in the file directly to the printer, so it's unlikely that the size of the print would be different.

I d/led gcode from Octoprint. Using Total Commander, the Octoprint GCode is identical to the original from Cura. I've also tried using Firefox vs Edge, same results. Was thinking it may be browser because my Amazon return code also print larger than expected.

I re-read your initial post and saw that you said the object printed LARGE. Please slice something small like a 5x5x5mm cube, upload the gcode here, print it, measure it, and post the results here.

If the model printed correctly but OctoPrint said its size was larger, then it is probably G0/G1 commands in the start and/or end gcode that OctoPrint includes in its size calculations but the slicer does not.

Thanks for cube suggestion. I did one and Model size showing as: 163.40mm x 180mm x 5mm. However, the print came out close to 5x5x5mm. I will ignore the "model size" since the prints are good. My first large print, still have no idea how or where I could have messed up measuremnts, but will call it user error :slight_smile:

yeah, this sounds like it's picking up the starting purge line in the gcode file.

1 Like

You could use this setting and have something after the purge line to skip to for size analysis.

Is the GCode analysis controlled by the GCode Viewer?

oh good point, that probably is for just the rendering of the file on the tab and not so much the analysis.

I guess a feature request is in order to add (optional) begin (and end) search string(s) to the analysis.

One could set the begin string to ";LAYER=1" and the end string could be set to a comment inserted at the beginning of the end gcode in the slicer. This would eliminate any start gcode and end gcode movement commands from being processed by the analysis.