Octoprint installation

What is the problem?
After booting the pi with the octopi image, I am able to login to the console and updated my password. I see that an IP address has been assigned. I also see that the device shows up on my UNFI router with IP. PRoblem:

I cannot ping it or connect to it

What did you already try to solve it?
Rebooted several times, verfied my SSID setting in the boot file.

Logs (octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support!)

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible)

is this ip in your local network address range?

yes, my network is 192.168.1.*. It assigned .65. I also tried plugging the network cable in directly and it assigned .64 to that port but I still could not ping or connect to it.

are you able to ping your pc or another device in your network from the pis console?

yes, I can ping other devices from the pi console

could be a firewall or something on your pc
are you able to connect to the pi with a smartphone or tablet?

I tried from my phone and still have same issue. I even disabled my pihole adblocking dns to test with.

One interesting thing I see when I run ifconfig on the pi is that I have:
I'm not familiar with the broadcast variable. Usually I would expect the gateway which should be

That's a good idea, to make sure it's not getting in the way.

The IP, mask and broadcast as issued appear to be correct but you also need a default gateway value (often .1 or whatever your router has).

The Pi computer should be able to:

ping  # Try to ping the router, confirming a default route
ping      # Try to ping google's DNS server, confirming Internet route

If your workstation is Windows-based, it could be your software firewall blocking ping. In a command window on Windows, you ought to be able to do a tracert to see where that fails.

The fact that you plugged in an Ethernet cable, the router could see that (as well as the wifi connection) and yet the (presumed) Windows-based computer can't connect either suggests that ssh isn't running on the Pi or that this is a routing configuration problem on the Windows computer. An OctoPi-imaged OctoPrint install will have ssh turned on by default, assuming that it's a newer version.

I can ping my gateway and with no problem from the pi. The traceroute from my laptop to the pi is as follows:
Tracing route to over a maximum of 30 hops
1 26 ms 20 ms 27 ms
2 * * * Request timed out.
3 * * * Request timed out.

I gotinto the raspi-config and tried to look at the network options. Here is what I found:

  1. Hostname: set to octopi
  2. Wifi: ERROR: could not communicate with wpa_Supplicant
  3. Enable predictable network interface names=> "Yes" =>Predictable network interface names are enabled
    4)Change wi-fi country=> ERROR "could not communicate with wpa_supplicant

I'm guessing this is the root of my problem. How to fix?

Assuming that you use the OctoPi image and applied this to a Pi computer...

Your /boot/octopi-wpa-supplicant.txt file upon bootup is used to configure the wpa_supplicant service. You shouldn't have to change that predictable name setting from the default.

Follow this advice for setting that up again.

I followed the directions to the t and still have the same issue.
Re-imaged, Updated the file with notepad++, booted, changed pw, ran raspi-config to update to latest.
WHen I look at network settings I still get the can't communicate with wpa_supplicant. I can also not run the Wi-Fi option or the Wi-fi localization country

I did some tweaks to the file and updated both the LOCAL and wireless locale and now I can get to the Wireless Screens and it allows me to enter my SSID and PW. It still cannot be pinged from my network. I can ping out of it and I can ping other computers from my laptop. I just can't ping the octopi.

Your traceroute shows the first hop as a 10.x.x.x address... But you said the pi is assigned a 192.168.1.x address. That is an issue... Is the laptop connected to your router, or the neighbors?


My guess is the PC is running a VPN tunnel so it doesn't see local devices. That would explain to 10.x.x.x. address.

On your pc what is the output of ipconfig?