OctoPrint installed on Rasbian webcam not streaming

Using a no name camera for right now as Webcams are sold out everywhere. I installed Octopi latest version over Rasbian as my Pi is also running PiVPN and Orchid for my cameras. The MJPEG streamer seems to work fine as I can hit the IP:8080/?action=stream in a browser and it works fine. The Snapshot URL Works fine and I can preview the image but for some reason the URL for the webcam stream just won't load in the front end of Octoprint.
I checked for a webcamd.log but there doesn't seem to be one. Probably a quirk of not using the image.

What stream url do you use?

Is an octopi thing.

I've tried a bunch of the same thing essentially. The IP if the pi is static'd.
So I've tried (which is the URL that works in browser) I've also tried localhost and etc. I've tried just the ?action=stream which I think what it auto completes to. When I preview the stream it shows one of those can't display image type of deals windows does. I will upload a pic when. I get back to a PC.