Octoprint installed with Python 3, and Python 2 plugins

Hi all

First post here (I think), be gentle with me :slight_smile:

I rebuilt my Octoprint server on a CentOS 8 box, got the WebUI to boot, mjpeg streamer working. Its all working as expected, and I was happy that bit all worked.

Then I discovered that the GPX plugin I needed to talk to my FlashForge Creator Pro is not Python 3 compatible :frowning: I installed Python 2.7 as well as keeping Python 3, but wondering how I can get the GPX plugin to show up in the list when I want to install it.

Would it be easier right now to wipe my Octoprint install and reinstall using the Python 2.7 environment? Can I swap the entire system over to using Python 2.7 instead of 3? Or A way to get just Octoprint to use 2.7 for now?

Although I am happy finding my way around Linux systems, I am not great with python, so any and all suggestions (no matter what they are) would be greatly appreciated.

Many thanks for the help!


That's what I would do :slight_smile:

1 Like

Did that, everything worked first time... excellent :slight_smile:

So, on CentOS 8, I did this:

sudo alternatives --set python /usr/bin/python2

$ /usr/bin/python -V
Python 2.7.16

and then

virtualenv --python=/usr/bin/python venv

1 Like