OctoPrint is disconnecting - Prusa MK3S+

What is the problem?

I was able to connect with OctoPrint to my MK3S+, but after some time I gen disconnected.
I tried to send Bed temp to set on printer but nothing is happening.

What did you already try to solve it?

No idea how.

Have you tried running in safe mode?

Yes

Did running in safe mode solve the problem?

No

Systeminfo Bundle

octoprint-systeminfo-20220712190200.zip (103.4 KB)

Additional information about your setup

OctoPrint version 1.8.1, OctoPi version 0.18.0, printer, firmware 3.11.0-4955, browser chrome, operating system Windows 11, Raspberry Pi 4B, connected directly onto the EINSY board

Logs:
octoprint.log (15.9 KB)
serial.log (4.2 KB)

Please help.

Regards,
Lukasz

There is a lot of communication corruption going on:

| Recv: Resend: 1
2022-07-12 18:55:20,073 - octoprint.util.comm - WARNING - Received an error from the printer's firmware: Line Numbÿÿ¿šŸ7·ÿˋëÊk½­)ÿýï»ÿ¿ýÿ•š½‘•¹)ßk
| Last lines in terminal:
| Recv: Ezror:line Number ÿ¿ûúÿ½ýgm§©kKøo±ßkê·­ëk¹½µµ…¹‘éÁLQ…PPPp"(2)
| Recv: ok
| Send: N11 M105*23
| Recv: Error:No Line Number with checksum, Last Line: 0
| Recv: Resend: 1
| Recv: ok
| Send: N1 M115*39
| Recv: õÿW¿¿ë鿚¬‹«åRú­)ÿoónKÿ·­ëkù‰Í½µµ…¹‘éLÁYPU@p"(2)
| Recv: ok
| Send: N2 M21*18
| Recv: Error:No Line Number with checksum, Last Nineº 0*Resund: 1
| Recv: ok
| Send: N3 M105*36
| Recv: echo:Unknown command: Ýma®²Ñ*'¥³“­j¿·µùecho:Unknown command: "ok"(2)
| Recv: ok
| Send: N4 M105*35
| Recv: echo:Unknown command: "eco:Un-command: "(2)
| Recv: ok
| Send: N5 M105*34
| Recv: Error:Line Numbÿÿ¿šŸ7·ÿˋëÊk½­)ÿýï»ÿ¿ýÿ•š½‘•¹)ßk

Something is probably interfering with the connection. Check all the wiring for issues, and routing of the cables is important to avoid noisy communication.

Ok, so I think, I have found an issue. Power needs to be connected to the printer, I was using an external source.