OctoPrint is running on a throttled system, updates are disabled

I was getting errors about an out of date Python on all my OctoPi's, I followed the FAQ and backed up and updated them all to "2019-06-24_2019-06-20-octopi-buster-lite-0.17.0.zip", but then it gave the above error, so I manually updated PIP to 19.2.3 and OctoPrint to 1.3.12rc3. Still the same error, so it say's it's running throttled, which it may be, but the RPi's vary 3B,3B+,4, they all have cooling fins and fans, and all run around 38C according to the toolbar addon. I've tried turning off Pi support, but it still seems to obey the throttle condition. So what to do next, how do I turn off this check?


This is one of them:

octoprint.log (14.4 KB)

This error can (and should) be ignored. See the details of this feature request. In theory, this is a part of v1.3.11 of OctoPrint now.

And this version, too, still has Python 2.7. There are times when pip might still whine about it (ignore).

Upgrading pip and upgrading python are two different things, btw.

None of this relates to a throttled Pi. You should determine what's causing the throttling by running some commands to find out why. Follow the commands there and then tell us if it's throttling due to power or heat.

And then again, you have both the Navbar Temperature and the Pi Support plugins. Both would tell you something I'm sure.

1 Like

Sorry, should have said, the Python error / update was about 2.6.x to 2.7.x not the v3 one.

The throttling code (vcgencmd get_throttled) returns:

0x5000 / 0b1010000000000000000


  1. under-voltage has occurred since last reboot!!
  2. throttling has occurred since last reboot
  3. arm frequency capped has occurred since last reboot!!

which is fine, they all have their own mini UPS boards, so I'd prefer a slightly low reliable voltage, than one that can cut out at any point.. Oh and the nav bar plugin shows 38C, and the Pi support says it's over temp..

But that doesn't really help with updating things..

So it's under-powered and too hot. I'd consider this the more important condition to worry about.

python --version
source ~/oprint/bin/activate
python --version

In theory, these are both the same (global versus the virtual environment you have for OctoPrint).

Caveat, I'm probably not the right person to tell you how to adjust the existing virtual environment's Python version in-place...

Honestly, this isn't the route I'd take. I would just flash from OctoPi and get the correct stuff this way.

deactivate # Assuming that you're still in the virtual environment
# Upgrade the global version of Python from 2.6 to 2.7.x
sudo add-apt-repository ppa:deadsnakes/ppa
sudo apt-get update
sudo apt-get install python2.7 python27-devel 
python --version

And then... the virtual environment may still be on v2.6.x.

source ~/oprint/bin/activate
python --version

If it's v2.7.x after this, then great but it won't be. It won't be because the ~/oprint/bin folder holds entries for python (symlink to an executable in the same folder) and pip. The whole virtual environment concept is to separate project requirements from each other's.

Thanks, but I think you misunderstood, Python is 2.7.13 everywhere, like I said, first thing I did was backup, re-image and restore all the SD cards as per the FAQ, I just need to know how to get OctoPrint to ignore the throttling error and start installing updates like it used to..

Perhaps @foosel could shed some light on this.

Thanks, yea, hopefully..

You can't. I've had way too many issues with users updating on actively throttled systems and causing file corruption or otherwise broken installs. You can always update manually through the command line, but automatic updating while being currently throttled is a no go now and I frankly don't want to add a flag for that since it will just make people run updates and break installations on unstable systems. The only thing you could do here is disable the Pi Support plugin but I frankly would recommend against that. If the Pi reports insufficient power, it's really insufficient power and not how you should run it. It causes hard to diagnose issues.


That, and undervoltage seems to be related to corrupted ext4 partitions on this as well.

1 Like

I guess it's up to you, but I'd have it as an option to ignore it, mine have all run like this for years without any issues, and if it hadn't been for the 2.6 to 2.7 python update, they'd have probably gone on running like it, but now I'm stuck on this version of everything, I hope there aren't any major bugs..

I was trying to find a solution because I could not update both the octoprint server and the psu add on. Updated the server via pip, and found that the USB light was the cause for the throttling of the RPi. Problem went away 10 secs after I unplugged the light and was able to update psu control via the octoprint dashboard. I guess I'm looking at a different way of lighting up my bed :frowning: :crazy_face: Hope this helps!

A smart plug with led strips plugged into it is a super easy way to light up the printer. Much brighter too.

Thanks for the suggestion. I just had a flexible usb light lying around that matched the PLA color I used for the mods and RPi case, so I thought it worked well without spending anything. Seems to do the job for my timelapses as well for what I need it to do.

Would getting a higher rating power supply mitigate the throttling? Or is it the actual load that causes it to throttle? I would think it was the latter, but just to clarify.

Does the pi also throttle with only the usb light and nothing else connected?

I run my Raspi 3 on a verified 5.2V 3A supply with a short fat cable and it's still complaining (but it's stable, ofc) (have a 5.4V supply incoming but seriously). I guess I'll disable the raspi plugin for now...

(I'm still not sure why it complains on the 5V rail since so few things run on 5V on the board? The design is strange.)

I totally sympathize with your decision though.

Measure the voltage across the GPIO 5v/GND pins. The Pi does not lie - we didn't make the Pi's undervoltage warning, it is a physical circuit on the board that trips if the voltage is below 4.65V.

If you are getting the warning, then the system is throttled. It isn't stable, because the Pi itself is limiting what it can do to try and function.

To quote myself:


the USB connection of some printers (Ender 3 v2 for me) requires a lot of power from the raspberry. I solved the problem by "masking" using adhesive tape the + 5v terminal of the printer connector