Octoprint issues after update

What is the problem?

After updating Octoprint the Octoprint webpage would be stuck connected to print and would not allow me to disconnect even if the printer was shut off. The web stream worked fine and I could go through settings and download logs and remove plugins but only through the IOS app could I connect serially and move the printer axes. Furthermore - I've always used Simplify3d and a Curl script to auto upload and start new prints and after the update when doing this is shuts down Octoprint until I SSH in and reboot it.

This issue is occurring on my Creality Ender 3, Flashforge Creator Pro, and Filament Innovations BFP310 all since I upgraded them at once.

What did you already try to solve it?

-Booting into Safemode
-Remove the plugin that also updated recently
-Removing other plugins
-Trying the FAQ forum advice(s) for a frozen Octoprint page
-Going to a known good backup for this setup - after restored backup the Octoprint version was still 1.4.2
-Updating the Rasbian OS (apt-get update etc)

Complete Logs

Logs.zip (226.3 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

-OctoPrint version 1.4.2
-Simplify3d 4.1.2
-MacOS 10.15
-Creality Ender 3
-Flashforge Creator Pro
-Filament Innovations BFP310
-Curl to API
-Running also on network a Linux server with SpaghettiDetective and OctoFarm
-Issue persistent / noticeable on Safari, Chrome, and FireFox

I would try to reinstall octoprint. Maybe something went wrong during the update

~/oprint/bin/pip install --force-reinstall OctoPrint==1.4.2
sudo service octoprint restart

I'm experiencing the same thing. Used to have rock-solid connectivity from Octoprint to my Ender 3 Pro and my Ender 5 Plus (both separate OP installs on separate Pi devices). After upgrade, and doing a forced re-install on both, connectivity is "spotty" at best.

The E3 is working more consistently - often doesn't connect automatically but then will connect when I manually click Connect.

The E5 is a lot less successful - doesn't connect most of the time, even manually, even after disconnecting the E5 from the Pi, restarting the E5, reconnecting [the cable], restarting Octoprint, and trying to connect again. I'm almost back to having to use the SD card in order to keep printing.

What's notable with the E5 is that when Octoprint shows disconnected and refused to connect (says printer is Offline), restarting Octoprint does cause the BLTouch to "twitch" and generally the E5 shows "life". This tells me that something down in Octoprint was connecting but that wasn't making its way up to the UI (or whatever layer is below that).

@VeryKross - Can you enable serial logging (Settings > Printer > Serial connection, scroll to bottom), then try and reproduce the issue? Would show if something is going wrong during the handshake etc.

I'll give that a try once this print is done (a couple more hours) and see what that tells us - hopefully some clues. As I said, it seems that some kind of connection is happening because you can see the printer respond, but the UI either reports a connection error or, after a long pause, reports offline. Sometimes rebooting OctoPrint fixes it but rebooting the System does not.

1 Like

These responses are consistent with my experiences also. If I use the IOS app I can move the axes and control the printer as well as the control tab on OctoPrint where I can use my keyboard when hovering over the webcam to move axes but not actually start an uploaded print.

If I upload the .gcode file to the webserver on my browser I can then use the app to start the print, but if I use the Curl script in Simplify3d OctoPrint locks up.

Hey @austin3dprinting, if you're having an issue with OctoPrint locking up on the curl script, can you get an octoprint.log, from when you can reproduce the issue? Will hopefully help massively, to diagnose the issue.

Thank you for the suggestion @Charlie_Powell. I'm uploading that in this response in case it is indeed helpful. Thank you!

octoprint.log (84.0 KB)

I figured out the issue. I protect my family from online content and use Apple's screen time restrictions on all our Macs and even with the "octopi.local" allowed, the Simplify3d Curl to the machine and the actual web page for the OctoPrint would act finicky like this. Once turned off everything worked fine again.