Octoprint keeps becoming unresponsive

What is the problem?

My Octoprint device was becoming unreachable last night during a print (couldn't connect to camera without it timing out and couldn't SSH to it), but overnight, it seemed to recover. It had done that in the past with longer prints, but I thought that issue was gone after I removed some plugins and just keep the bare minimum. Then, I tried uploading new files to it this morning and they kept failing so it said to download the octoprint.log. After I got the log, it became completely unreachable and I couldn't SSH to it and the portal wouldn't appear in a browser. After turning it off and on again a few times, it eventually came back, but I wondered if anything in the log or bundle might shed light on what might have happened. I do not know Linux so my ability to troubleshoot is limited.

What did you already try to solve it?

Removed plugins, safe mode, reboot.

Have you tried running in safe mode?

Yes

Did running in safe mode solve the problem?

No

Systeminfo Bundle

I know it says to not touch the bundle, but it was bigger than 4 MB so I unzipped it and then rezipped it more compressed to get it under 4 MB. If I should upload it another way, please let me know.
octoprint-systeminfo-20220530155036.zip (3.7 MB)

WRITE HERE

Additional information about your setup

rowser.user_agent : Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/101.0.4951.64 Safari/537.36 Edg/101.0.1210.53
connectivity.connection_check : 1.1.1.1:53
connectivity.connection_ok : true
connectivity.enabled : true
connectivity.online : true
connectivity.resolution_check : octoprint.org
connectivity.resolution_ok : true
env.hardware.cores : 4
env.hardware.freq : 1500
env.hardware.ram : 3959984128
env.os.bits : 32
env.os.id : linux
env.os.platform : linux
env.plugins.pi_support.model : Raspberry Pi 4 Model B Rev 1.2
env.plugins.pi_support.octopi_version : 0.18.0
env.plugins.pi_support.throttle_state : 0x0
env.python.pip : 20.3.3
env.python.version : 3.7.3
env.python.virtualenv : true
octoprint.last_safe_mode.date : 2022-05-30T13:13:28Z
octoprint.last_safe_mode.reason : settings
octoprint.safe_mode : false
octoprint.version : 1.8.1
printer.firmware : Prusa-Firmware 3.11.0 based on Marlin
systeminfo.generated : 2022-05-30T14:57:56Z
systeminfo.generator : systemapi

Thanks!

Do you always run with DEBUG mode on?

Your octoprint.log is 88 125 077 bytes long with 814 183 lines.

Without the DEBUG info it is 1 524 394 bytes with 16 147 lines. This is almost only 2% of the original size.

The DEBUG recording costs you an amount of space in the log, a lot of calculation time a unnecessary CPU load.

Due to this, the system gets also unresponsive for other services like obico and internal things.

And please don't power cycle:

2022-05-30 15:44:51,821 - octoprint.util.connectivity.connectivity_checker - INFO - Resolving octoprint.org is not working
2022-05-30 15:17:07,025 - octoprint.startup - INFO - ******************************************************************************

You also may check your web connection to obico.

Thanks for your response! I may have set it previously to troubleshoot (or out of ignorance) and then forgotten. Guess that's why I couldn't upload it all. DOH! Glad you caught that. Should all of the logs just be set to INFO? Couldn't remember what the default was. I already have changed them and hope that does the trick!

Oh, and if I can't login to it, how am I supposed to restart it without power cycling it? I know (from Windows) to avoid cold reboots, but sometimes, there's no other option?

1 Like

On the Raspberry Pi you usually use the System button:

grafik

Yep, I normally use that, but the interface wasn't responding so I couldn't get to it.

Ok, in case of emergency...

1 Like

I'd suggest that you troubleshoot and solve your network connection issues. All of my RPi systems have solid WiFi network connections so SSH is always available. You may need to change the WiFi channel you use.

It wasn't a network connectivity issue. It was the performance of the Pi. Once, SSH kind of connected and then hung. That was when the portal wouldn't completely load. I have other devices on that same network that were working fine.

Sounds exactly like my issue in the other thread, CPU Load 100% (or reported even higher) and not reachable anymore via SSH. Sometimes healed itself after leaving it on for some hours. Problem only occurred after updating to 1.8.0 / 1.8.1, never before that.

Problem seems to be gone after I disabled alot of plugins, not sure what caused it finally, but until now it is working fine again.

If the network issue is not the problem you are looking into, then you also have a network issue, or at least the Obico plugin has an issue connecting to it's servers a lot through the log.

Could anyone provide recommendations on log settings since I had them turned up way too much? So far, removing debug has seemed to make my poor little Pi much happier.

There shouldn't be a need to have anything on debug unless debugging, the usual info level logs are quite quiet outside of server startup, there's not a lot happening. Of course, that only speaks for core OctoPrint - plugins may act differently. Everything set to info works for vast majority and is the standard.

1 Like

Also consider temperature, your pi will slow down if it gets too hot.

From the logs it seems there are no temperature issues.

Hi all. As soon as I marked the logging change as the solution, the issue returned. I just had the same problems with the pi webcam not responding and SSH just showing a blank screen and then eventually, I couldn't even get a response from a TCP test to connect to 443 or a ping. I just rebooted in safe mode and tried uploading a file and that failed again. It's just really slow and non-responsive. Here's the new bundle. Any thoughts?
octoprint-systeminfo-20220604172943.zip (1.4 MB)

Hey Ewald. Since you noticed the debug issue, I wondered if you could take a look at the latest bundle since this is still happening, even after turning down the logging. Yesterday, it became unresponsive for a while and then a bit later, I was able to connect again. I also had by obico upgrade just fail and didn't know if it was related. Not sure if a reload of Octoprint is necessary or if I have some hardware issue. Appreciate the help!
octoprint-systeminfo-20220612171303.zip (60.8 KB)

Obico really has a hard time to get connected to the server to run smoothly.

You may try with Obico disabled.

If it runs smootly, you may swap to another remote service:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.