Octoprint kept disconnecting from USB serial. And I think I found the culprit. RF interferences from VR headsets

What is the problem?
USB connection intermittently disconnected.

To save your time. This topic is about how I fixed (found) the issue. I'm just sharing my experience with those who will suffer with similar issue.

Octoprint kept disconnected from 4 of 3D printers intermittently at random timings. I have been running Octopi on a Rasberry Pi 4 with 4 octoprint instances without a problem for the last 8 months. Then suddenly the USB disconnecting issue started without any direct changes to the 3D printing environment.

The Octoprint provided the error message of ['Too many consecutive timeouts, printer still connected and alive?'] randomly while in just standby or in the middle of print.

I use the power supply from the Pi foundation (5v/3A) and the red LED on the Pi was stable all the time so I assumed it wasn't the power supply issue. I even tried 5v/4A power supply but it didn't make any change.
I use the proven USB cables that I know it's been working fine with my other data intensive devices so I though the cables were not the cause.
I used [htop] command to monitor the Pi resources and it looked there were plenty of resources available most of the time.

I tried all sort of trouble shootings that I could find on the Internet for two days without luck. I found that at some period of the time, the connection was very stable for almost half day.

Then I came to think about any other changes that happened 'outside' of the 3D printing environment. Then I remembered that I have received a couple of VR headsets (Meta Quest 2) on the day the issue started. I left the VR headsets to on a table to charge in my living room - my printers and the Pi are in the garage.

Then I realised that the straight distance of the VR headsets and the Pi and the printers are not that far because my garage is right next to my living room with a timber wall in the middle. The straight distance from the VR headsets and the Pi was probably just about 50 cm or less. The VR headsets have all the RF devices packed in the body and the controllers such as wifi and bluetooth.

I removed the VR headsets to give more room from the Pi then, viola! the issue is gone and the printers are up and go again.

I'm not sure exactly what part of of the 3D printer environment was getting the RF jamming from the VR headsets. If it was the Pi or the printer boards or the USB cables or all of them were getting the jamming.

I'm thinking of covering the wall with aluminium foil behind the Pi and the printers to cut off any possible interferences in the future.

After fixing my issue, I came across to an article that was about RF jamming on RPi4. It's not exactly same issue as mine, I think it's worth noting that RPi4 are a little prone to RF jamming by nature.

What did you already try to solve it?
Restarted all and individual devices that are 3 Ender 3 V2s, 1 Prusa MK3S+, Rasberry Pi 4 and TAPO wifi IP camera.
Updated the Octoprint from 1.7.2 to 1.8.1
Swapped the SD card from 16GB to 32GB with freshly installed OctoPi.
Tried swapping the power supply from 5v/3A to 5v/4A.

Logs (syslog, dmesg, ... no logs, no support)
2022-06-26 17:54:50,559 - octoprint.util.comm - INFO - Communication timeout while printing, trying to trigger response from printer.
2022-06-26 17:54:53,564 - octoprint.util.comm - INFO - No response from printer after 6 consecutive communication timeouts, considering it dead.
2022-06-26 17:54:53,626 - octoprint.util.comm - INFO - Changing monitoring state from "Printing" to "Offline after error"
2022-06-26 17:54:53,649 - octoprint.plugins.action_command_notification - INFO - Notifications cleared
2022-06-26 17:54:56,873 - octoprint.plugins.tracking - INFO - Sent tracking event commerror_timeout, payload: {'commerror_text': 'Too many consecutive timeouts, printer still connected and alive?'}
2022-06-26 17:55:00,978 - octoprint.plugins.tracking - INFO - Sent tracking event print_failed, payload: {'origin': 'local', 'file': 'c1ff1c4942c9ad25cd670bda350b2c4b26f0ffd8', 'elapsed': 620, 'reason': 'error', 'commerror_text': 'Too many consecutive timeouts, printer still connected and alive?'}

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)


thank you so much for charing !
Just what I like to know.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.