Octoprint.local not working

What is the problem?
can't seem to find octoprint device when trying to ping

What did you already try to solve it?
checked the network name I type was the same and made sure it was on the right country since I am using a 3b +

Logs (syslog, dmesg, ... no logs, no support)
ping: cannot resolve octopi.local: Unknown host
Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...) I am trying to connect to an extender not sure if that is the issue but for some reason, its not wanting to connect to the access point to the pi. I don't have a screen to plug the pi to. so im trying to do it headless by activating ssh.

does just octopi (instead of octopi.local) work?

no it doesn't for some reason its not detecting anything. could it be that it was flashed wrong on the sd card?

I have flashed it twice through pi manager

It is possible, but I think it is unlikely.
I would connect the pi via ethernet cable to rule that out. You can also try to connect to your wifi while it's connected with via ethernet.

Scan for available networks with sudo iwlist wlan0 scan

Also take care that there is no www. appearing in the address. SO it should look like this:

http://octopi.local

I am unable to connect to http://octopi.local, or octopi or using my IP address.
Cannot Connect Web Interface 2023-01-14 mod

I have so far only tried using Microsoft Edge to connect.

I have a Pi 4B running Pi OS x64.
| hardware:
| cores: 4
| freq: 1800.0
| ram: 1939075072
| os:
| bits: 64
| id: linux
| platform: linux
| plugins:
| pi_support:
| model: Raspberry Pi 4 Model B Rev 1.4
| throttle_check_enabled: true
| throttle_check_functional: true
| throttle_state: '0x0'
| python:
| pip: 20.3.4
| version: 3.9.2
| virtualenv: /home/*Personal*/OctoPrint

I have it connected using an ethernet cable.
I installed Octoprint following the instructions on OctoPrint.org - Download & Setup OctoPrint, Manual Install.

I can connect using SSH (Putty) & VNC (Real VNC).
My username is not "pi".

I have attempted to rerun the installation process again and was shown everything was already correctly installed.
I have tried using a command that tells Octoprint to restart but I would get an error message. I believe it stated it could not find system files. Sorry I don't have the exact wording for both the restart and error message.
Friday evening just before I turned over and gave up, in SSH I ran "./OctoPrint/bin/octoprint serve" and it ran until it got to "Fetching check overlays from https://plugins.octoprint.org/update_check_overlay.json. This step always takes time.
When I checked this morning, I was seeing "2023-01-14 14:26:40,296 - octoprint.server.heartbeat - INFO - Server heartbeat <3".

So, it seems to be running.
So right now I am out of ideas of how to proceed.
Some might be asking why I don't just use the Octiprint image. Because I have other stuff I wish to run at the same time. I felt this was going to be the easiest way. Jokes on me I guess.

Thank you for all of your help.

From the local machine.. Seem you only have command line, no gui, so what happens when you do a Curl on the url, you should get something back.. If you do and its the 401 or for authentication, likely means your server is running. Maybe you did not open the port or maybe you think it is on a different port than it is. I run all my instance on a linux disto and the default is 5000 so that might be a place to start.

I would be trying it with just the IP and the port...
Something like(from a remote machine):

http://192.168.0.100:5000

and something like this( from the same machine)

https://127.0.0.1:5000
http://localhost:5000

If you set a specific port, use that instead of 5000 or do not use port if you set it to 80 for sure.

Hello, thank you for the very quick reply.
I am extremely new to all of this so I will need a bit more information.
What is "Curl".
When I ran the setup, I was not asked about a port setting. So, I assume it is whatever is default.

Thank you again.

Likely you are using port 5000. Try the urls that I posted in previous.. see if you can get the one with your known IP to work.

For some details on "curl" its a way to pull responses(most of the time files) from a internet url in a terminal session. Here is the man page. I am sure you can find a lot of examples if you do a little googling.

curl might need to be installed but likely it is already installed.

If you are not using the OctoPi image, then octopi.local will not work for you. This is specific to that OS image.

If you haven't done the reverse proxy setup then you will have to use port 5000 as well.

Hello, so I tried the URLs above and no luck.

But there was a difference, when I used the first one with the Pi's IP address the message said "IP:5000 refused to connect". Tried just with the IP address and received the same error.

While I was logged into the Pi gui (VNC) and looking at the ethernet connection icon in the upper right (two arrows). It showed that the Pi was connected using ethernet, then the IP address, and then it had "/" and a number. Does that number mean anything?

Sadly, nothing worked for me.
I again verified that my router saw the Pi. Verified the IP address which I locked to the MAC address.

Just for clarification.
Remote Machine is my pc (not directly connected to Pi).
Same Machine is the Pi.

Thank you again for your help.

Try this one from firefox on your Pi (GUI)
http://localhost:5000/

This should work even if your firewall is blocking external connections on port 5000 to the Pi. If this does work, and you are not able to use a version if the actual IP of your Pi in place of "localhost" than you need to open that port on your Pi. How you would do this can be dependent on the distro you are using. That said, take a look at this. It has some good tips on how to look at what is listening on your device and how to open the port if you need to. How To Open a Port on Linux | DigitalOcean

So I just tried and I received the same error.

I am thinking I have another MicroSD card. I might try loading it with the Octoprint image and see if that works. I am also thinking of setting up an old laptop to image and work with the Pi. I had issues with the Pi Imager not creating my specified username and password.
I am wondering if something on my main computer is disrupting my trying to get the Pi working.

It is a long shot, but I am just becoming aggravated. Which then effects my problem-solving skills.

I will update you later.
Again, thank you for your help.

Hello, some updates.
I took my other SD card and download the Octopi image by Guy Sheffer " GitHub - guysoft/OctoPi: Scripts to build OctoPi, a Raspberry PI distro for controlling 3D printers over the web".

I installed it onto my SD card using the Pi Imager.
I was able to instantly connect to Octopi using my web browser.

I took my original SD card and installed Pi OS x64. I logged in to my Pi using SSH and finished the setup. I am able to connect to my Pi using VNC.

I opened the Pi terminal on the Pi desktop and then I followed the instructions to manually install Octoprint onto my SD card.

After everything was installed, I tried to log into Octoprint using all of the recommended ways in this forum. Nothing worked. I then went to the suggested website on how to open a port.
I was unable to open a port number 5000.

I even then tried logging in using some of the already open ports but nothing worked.

So, I have given up and I have gone back to the working setup.

I don't know what I am missing when it comes to getting the other setup to work,

Hope this helps someone else who might have the same issue.

Thanks to everyone that offered their support.