Octoprint looses USB connection with printer repeatedly

When I print through SD it now works fine and has with octoprint, but now out of nowhere it quits. Could it be my board? I have the MKS Gen L V1.0. it has gone through alot of power shortages due to the breaker tripping, could it have friend something important with communicating through the USB serial in the process? I have a new board coming in and will give that a try to see if anything changes. It also stays connected to octoprint and will even do movements and send the print, but after a minute it disconnects.

I'm pretty sure that foosel asked for the serial.log. You'd want to turn that feature on in Settings, run your printer until it misbehaves and then to upload that here.

serial.log (19.8 KB)

2019-02-02 01:31:17,690 - No response from printer after 3 consecutive communication timeouts, considering it dead. Configure long running commands or increase communication timeout if that happens regularly on specific commands or long moves.

OctoPrint gave up after not hearing back from the printer.

M104 S250 Is there a reason why you're trying to heat the hotend this much? That's pretty hot.

im printing with petg and after a temp tower test came to the conclusion of using 250, but have bounced around from 250-240

is there a reason why it wouldnt be hearing back from my printer? maybe an issue with the usb interface?

From your log:
Send: M155 S2 <-- Automatic Temperature Monitoring, produce a Temperature Message every 2 seconds.

And then, later when you are heating the nozzle:
2019-02-02 01:30:56,674 - Recv: T:77.81 /250.00 B:80.12 /80.00 @:127 B@:17
2019-02-02 01:30:58,673 - Recv: T:83.17 /250.00 B:80.11 /80.00 @:127 B@:17
2019-02-02 01:31:00,674 - Recv: T:88.05 /250.00 B:80.19 /80.00 @:127 B@:9
2019-02-02 01:31:02,676 - Recv: T:93.94 /250.00 B:80.19 /80.00 @:127 B@:8
2019-02-02 01:31:04,673 - Recv: T:98.97 /250.00 B:80.02 /80.00 @:127 B@:24
2019-02-02 01:31:06,674 - Recv: T:104.14 /250.00 B:80.00 /80.00 @:127 B@:25
2019-02-02 01:31:08,673 - Recv: T:109.08 /250.00 B:79.91 /80.00 @:127 B@:32
2019-02-02 01:31:17,690 - No response from printer after 3 consecutive communication timeouts, considering it dead. Configure long running commands or increase communication timeout if that happens regularly on specific commands or long moves.
2019-02-02 01:31:17,708 - Changing monitoring state from "Operational" to "Offline (Error: Too many consecutive timeouts, printer still connected and alive?)"
2019-02-02 01:31:17,718 - Connection closed, closing down monitor
The messages just stop at 2019-02-02 01:31:08,673, until then they had been coming every 2 seconds as requested. So Octoprint times out, ok. But: If the printer has a display, I would like to know: Was ist still alive and responding to button press, was the display updating temperatures. In other words, was Marlin really hung up or has Marlin just lost the USB connection?

Similar for me... I uses OrangePi Lite. I printed only twice with the setup (I had not enough time to massively experiment with this). The first print (20min - xyzcube) went well. But the second stopped midprint (after ~1.5h). I thought maybe my embedded-computer is too small, but the logs reported that everything in the "server" side went "normal" and the connection failed. I tried to preheat the head to remove it from the print, and I get multiple reconnections in the process (which every time rebooted my ender3, so I just unplugged it, and freezed the idea to print with octoprint for a while).

My cable is a short and simple cable, I would be thrilled if the pi-to-printer interference would be the problem.

So just to summarized the possible solutions here:

  • change the usb cable to a shorter one
  • change the usb cable to a short shielded one (maybe shield your cable manually)
  • look into the board and try to shield inner serial cables
  • look into the board and try to shield everything which can be a communication channel

Which is better, using pi powered mode, or separated VCC mode? (I mean if I breake the usb VCC that will help or make it worst?) Any Ender 3 related tip? The prev. problems are get solved with one of these tips or not?

I have been having usb connection problems for several weeks now. This is an old post I created when the problem started.

Now my CR-10 works fine but my ender 3 fails repeatedly within 10 to 20 mins. I have tried ...

  1. moving the power cord from my garage to the house
  2. adding usb isolator
  3. replacing raspberry pi
  4. replacing raspi power adaptor
  5. replacing raspi power cord
  6. replacing ender 3 usb cable
  7. replacing ender 3 controller with an MKS GEN 1.4
  8. tweaking my marlin firmware.

As you can see there is no hardware left to replace except the ender 3 itself but replacing the controller board is the same thing, right? Since I've replaced 100% of the hardware I'm thinking it is software. Either Marlin or Octopi.

Any suggestions?

I fixed it. I realized there was one thing I hadn't replaced, and that was the SD card. When I replaced the raspi I just moved the card over. I took a fresh SD card and loaded the latest octopi and configured a vanilla octoprint with no plugins. The problem is gone.

I'm guessing one of my many plugins was causing the problem. Unfortunately I don't have the time to try plugins one-by-one to isolate the bad one.

So after two weeks of suspecting hardware I've found that the problem was software.

1 Like

Well, that's why "try it in Safe Mode" is usually the first thing we'll suggest here. It will simply load up OctoPrint without any of the plugins which weren't originally bundled.

It's hard to admit but my problem was a raspi supply too weak, just like many others experienced and suggested. I was using a 1 amp cellphone charger and the one I changed to when testing was also 1 amp. Different things would help because the problem was so sensitive. Removing the plugins helped, I assume because there was less load.

The problem wasn't totally fixed until I switched to a 5V 2.5 amp charger.

Thank you for getting back to us with this piece of information - you won't believe how often it is the power supply, and how rarely people believe us when we point that out. The power management on the Pi is finicky at best, and the beast tends to do hilarious things when browning out due to not getting not enough juice. Biggest source of issues at this point really.

I'm having problems staying connected to the server. I'm new at this but have put a ton of time and patience into getting everything working and accessible from both home and work. I thought I was finally there and now every print stops under an hour or so into it and I can't connect onto the server again either for several hours or I have to turn off and on my printer. When this happens the ip address doesn't show up on the router, and it becomes inaccessible from putty. I don't know what else to try, I've tried wifi and Ethernet and they seem to get the same result. I just tried it with octopi in safe mode and got the same results.
I don't or barely can understand the logs but here's the latest two crashes that happened. When this happens and go back to my prusa mks3 with a raspberry pi zero, it's error is the heat bed timed out.

I don't if it's on octoprints side or the router. Any help with be so very appreciated.

Thank you![serial

octoprint 1. 1-28-2020.log (623.8 KB)

octoprint.log (480.1 KB)

octoprint 2. 1-28-2020.log (660.1 KB)

my prusa mks3 with a raspberry pi zero

Contrary to what Prusa Research recommends to run with their printers the 0w is not recommended for OctoPrint - it causes all kinds of issues due to being ridiculously underpowered for the task, especially with the number of third party plugins you run on top of everything else. And as if the performance issues weren't bad enough, attaching it to the Einsy as recommended by Prusa will also mean the Pi just gets shut off without a proper shut down on every printer power cycle, which greatly ups the chances of file system corruption and thus a broken install that no longer functions as expected. From the looks of your log that has also happened here by now, so the best idea would probably be to reinstall.

I'd suggest to get yourself a Pi3 and install OctoPrint the recommended way, with the official OctoPi image. That way it's also way easier to provide you with support, and you are less likely to run into issues due to the suboptimal setup propagated by your printer's manufacturer.

Side note: It's not the first time I really wish they had talked to me before going the 0w-on-the-Einsy-route, it would have saved a lot of their customers a ton of grief and me a ton of support overhead :confused:


Thank you for the quick response!

I've often wondered if I should just make the switch but I do like it being able to be some what built into the unit and having just the one power cord.

Will the pi 4's work just as well as the pi 3's? I would imagine so but just to check.

I've started playing with the pi 4's of late both because of these issues and because I'm wanting to get more into into programming and electronics.

My question is, is there a way to have two things on one memory card/ pi 3 or 4? Like can I use the regular raspbian install and the octoprint install on the same memory card? Or is it just meant and needed to have a dedicated card for each?

This reminds me of the guys in Tennessee (I'm from there so I can make fun of them) who have two cars but only one license plate and battery between them. (microSD cards are cheap enough, I'd dedicate one for each.)

The pi4 will work too, yes. Use one dedicated card per OS.

1 Like

Thank you!

It's so nice to have someone there to help when it's needed and it actually took me by surprise that I got one at all, let alone that it was you and quick response.

1 Like

Yes, she's amazing and she also has a tip jar. :sunglasses:

1 Like