OctoPrint Missing Plugin/IP Issue?

So I recently started to use OctoPrint (version 0.16) to control two printer instances using Chris Riley's Youtube guide and everything has been good so far. It was only until I tried to install the Filament Manager plugin where things started to fall apart. After restarting Octoprint, the first bad sign was the filament manager plugin did not show up in the plugin section. Had no success refreshing the browser or installing the filament manager again did I try updating my Octoprint version 1.3.10 to 1.3.12. However, it failed to update as well. I've been digging around this forum for solutions and I tried everything from the Connectivity Checks to various reinstall or update lines through Putty. I think it may be a simple issue with the IP but I want to make sure that is the case since I kinda suck in coding :stuck_out_tongue: (this is me guessing since I have seen my errors come to a common message: module object has no attribute ip_address).

Here are the logs that Octoprint told me to get after the error occured: octoprint(2).log (145.3 KB) plugin_softwareupdate_console.log (11.2 KB)

Looks like a corrupted install to be honest. Are you in the habit of not properly shutting down the Pi before removing power from it?

You could try this via SSH/PuTTY:

sudo service octoprint stop
mv ~/oprint ~/oprint.old
virtualenv oprint
~/oprint/bin/pip install octoprint
sudo service octoprint restart

The will create a new virtualenv in the hopes that it's only the existing one that's broken, and then install OctoPrint into it. Your settings should be kept.

1 Like

The FilamentManager could not be started because one module is missing:

2019-10-28 06:04:49,323 - octoprint.plugin.core - ERROR - Error loading plugin filamentmanager
Traceback (most recent call last):
  File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint/plugin/core.py", line 847, in _import_plugin
    instance = imp.load_module(key, f, filename, description)
  File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint_filamentmanager/__init__.py", line 17, in <module>
    from .data import FilamentManager
  File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint_filamentmanager/data/__init__.py", line 11, in <module>
    from backports import csv
ImportError: No module named backports

Try to install "backports" manually (backports.csv>=1.0.5,<1.1)

An other weird think is this error message:

  File "/home/pi/oprint/local/lib/python2.7/site-packages/urllib3/packages/ssl_match_hostname/_implementation.py", line 109, in match_hostname
    host_ip = ipaddress.ip_address(_to_unicode(hostname))
AttributeError: 'module' object has no attribute 'ip_address'

Maybe a total new installation could help.

I just tried your code on Putty and I think it did the trick, since now the Octoprint is now on 1.3.12. I did lose all my plugins but thats an acceptable loss. Another problem came out, in which now I cannot access my other printer instance and it gives me an internal server error that states "The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there is an error in the application." Any way to resolve that issue? Thanks!

No idea based on that but given the error message I strongly suggest to take a look into the logs.

I'm also not familiar with the steps involved into setting up a secondary instance outlined in that video (I think I haven't watched it, can't right now) so can't really help a lot there. Plus, I don't officially condone parallel instances (yes it can work, but when it doesn't I don't want to be the one having to support it on every single low powered piece of hardware under the sun).

1 Like

Oh sorry I forgot to include the log data. So I just checked back on the Pi and magically after 8 hours, both instances now show, on my Pi, which is a good sign. However, when I download plugins for one printer (IP 192.168.x.xxx), those downloaded plugins do not show up on the 2nd printer (IP 192.168.x.xxx:5001). I learned how to do instances via Chris's basement Youtube video. Would it help if I showed you what code I put into the Pi via Putty when I was creating those instances? I also attached my recent log from 1st printer hoping it highlights the plugin issues. I tried to get the logs from the second printer (the IP with the 5001 port reference) but it gives me this error message: "The site at h ttp://192.168.x.xxx:5001 /downloads/logs/octoprint.log has experienced a network protocol violation that cannot be repaired. The page you are trying to view cannot be shown because an error in the data transmission was detected."

Edit: Forgot to upload log of first printer and somehow managed to retrieve log of second printer from a different computer (also couldnt directly upload onto this post so hopefully this google link works)
Edit2: Just found out why I couldnt upload the log data directly: octoprint(3).log (451.2 KB) octoprint_TORNADO.log (427.4 KB)