Octoprint No interface, only webcam


#1

first off, ill just say this is my first time doing anything with a rpi, or a 3d printer. this is all new to me and im doing my best with google and youtube. finally after fighting my modem and router (and useless isp help line) i figured out i was behind a double nat. bridged modem, now i can port foward, using no-ip.com i can access octoprint... kinda. that was the biggest hurdle and at least that is now working, but...

What is the problem?
when using my public ip (or going thru the no-ip url i created) to get into the pi/octorpint, i only get a white page with a stream and a still form my cam. no octoprint interface. so, at least im making it into my network and onto the pi.

when i access it locally with its local ip, it works fine and all interface controls are available.

(yes i know the image is upside down :slight_smile: its just sitting on the floor beside a powerbar. ill position it once its working)


What did you already try to solve it?
nothing!! :slight_smile: this is step one. i didnt even realy know what to google as a problem, and what i did search turned up no results.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

ocotopi 0.15.1, ocotoprint 1.3.8 on rpi 3b+

if any additional info is required, ill do my best to provide it, though i may need instruction on how to do so as i know nothing about linux and pulling up logs from the pi.

thanks!


#2

Did you type the IP like aaa.bbb.ccc.ddd:8080? In that case, you just get the webcam.
Just try the IP like aaa.bbb.ccc.ddd

Edit: Sorry, can't verify. I've disconnected my printer because I'm moving...


#3

just tried it, but unfortunately that doesnt work. it just sits there "connecting..." and eventually times out. the only way i can get it to do anything, ip or with no-ip url, is to include the port, and again, that just takes me to the pi cam as shown above.


#4

Did you install an OctoPi image?
Or did you install OctoPrint manually on Raspbian?
Maybe the OctoPrint service is not running.
You can get information about that here: https://discourse.octoprint.org/t/setting-up-octoprint-on-a-raspberry-pi-running-raspbian/2337


#5

yup, thats what i did (the top part of the link)... followed a video on youtube, downloaded an image, flashed it to an sd card, and booted it up. as i said, i can get it to fine when i use its local IP..., its the external IP that is the problem.


#6

It looks like you did your port forward to port 8080 (the webcam server). You need to do it to port 80 (haproxy in front of OctoPrint and the webcam server) instead.

See also


#7

that was it, i was using 8080. setting it to 80 works. i only used 8080 because someone else used it somewhere else as i was reading for answers. i didnt know that was the webcam port.

thanks very much for the help!


#8

Great! Please mark the solution then via :marksolved: so others stumbling over this can more easily find it in the future.