OctoPrint no longer connecting to Printer

What is the problem?

Yesterday I had no issues with the connection between my Pi (via OctoPrint) and my printer (Creality CR10s Pro V2), but today I'm getting the error " State: Offline after error No more candidates to test, and no working port/baudrate combination detected." The main variable that changed is that I updated my Mac to Big Sur in between the time it worked and the time it stopped working (between yesterday and today). I'm not sure that's the issue though since I am indeed able to connect to OctoPrint via the browser just as I've always done. It is connecting to the PRINTER that is the issue.

What did you already try to solve it?

I updated the OctoPrint OS to the latest version, I swapped out the micro USB cable between the Pi and the Printer (with 3 different cables), I've rebooted OctoPrint in Safe mode, and Rebooted the printer and the Pi several times.

Have you tried running in safe mode?

Yes, no difference.

Did running in safe mode solve the problem?


Systeminfo Bundle

octoprint.log (998.7 KB)
serial.log (1.5 KB)
octoprint-systeminfo-20210507231858.zip (78.0 KB)
oftwareupdate_console.log|attachment](upload://i89zdjaeq53lgDLK3UXR8Nb5foC.log) (98.7 KB)
plugin_pluginmanager_console.log (12.5 KB)

Additional information about your setup

I think most of the system, OS, version, etc info will be in the bundle but if you need anything else please let me know.

Hello @deilers !

At very first I'd strongly recommend not to pull the power plug of the Pi to restart it. This can cause issues on the SD card so it can get corrupted.

To check if your printers USB connection is fine, you may run pronterface and connect it to the printer.

As for your profile, you have two printers. Does the Pi connect to the other printer?

Thanks for the reply @Ewald_Ikemann .

The other printer is controlled by a completely separate Pi system, and is not where I am at the moment so I cannot test. I can say that only the CR10 shows as an option in OctoPrint in my browser.

As for Pronterface, I'm a Mac user running Big Sur OS, which is a lot more picky than previous versions about installing open source software. Looks like the last modified version is still from 2017, so unfortunately I won't risk installing it. Are there any other ways to test the actual USB port on the printer without installing open source software?

Anyone have any other thoughts on why this might be happening?

Let's check if the pi is able to detect the printer at all.

Log into your pi via ssh then disconnect your printer, connect it again, enter dmesg | tail -n 20 and post the output here.

If you need help with the ssh part
Scroll down and start with the Connecting to Your Raspberry Pi over SSH part.
The first part is already done for you in the octopi image.

Thanks for the clear instructions @PrintedWeezl . Attached is the output you requested.

Unfortunately the doesn't detect the printer.
You could try the other cables and check again if there is more in dmesg.

If you still don't get anything we should really connect the printer to your mac to rule out the pi.
I can't tell you what other software you could use because I have never worked on nor seen a mac before.
I guess dmesg would also work on MacOS, you might need to run it with admin/root privileges.

Thanks @PrintedWeezl for the help. I connected the printer to my Mac and saw no signs of life whatsoever. I opened Octoprint and it didn't seem to notice any new ports. I also didn't see anything on my Mac signifying that there was any kind of connection either. I think it may be that my USB port on the printer somehow went bad. Perhaps i knocked it at some point and just didn't realize I had.

Possibly the USB cable, possibly the port, both can die. If I'm reading correctly, you've tried 3 different cables, it's usually the cable that breaks or doesn't work in the first place (power only cable).

Did you try and do the 5V tape fix? Sometimes people miss and partially tape over the data pins. Just wondering.

I'm printing at the moment, but will try the tape fix just to rule it out. Now that I think about it, the printer display has not been coming on since this issue began and prior to that the printer display would always light up when the Pi powered on and the printer was off. So, that is actually one way (I think) to rule out the Pi's USB ports as being the issue. IF I can charge my phone while plugging the USB cable into the Pi, BUT the same cable does not light up the printer's display like it used to, I think the safe bet is that the USB port on the printer is fried.

Does anyone else know of a simply way to test the USB port on either the Pi or the Printer besides the above?

You can test the USB A port(s) with a flash drive.

You can often test a USB cable with a cell phone (or tablet) that uses the same USB connector as the printer. The cell phone should show up as a memory device just like the flash drive. If the cable is a power only cable, then the cell phone won't show up as a memory device (but should indicate that it is charging).

Note that some specific Creality printers (i.e. a specific printer, not a model specific problem) have still not worked with a USB data cable that works with a cell phone. The USB cable needs to be shielded and should have ferrite beads on one or both ends. You may have to try different data cables until one works.

A Creality printer may be sensitive to both the length of the cable and how it is routed. Also, the routing of other cables around the control board may affect the success or failure of the USB port. In other words, Creality printers seem to be both susceptible to EMI and generators of EMI.