Octoprint no longer connects to printer

What is the problem?
My folgertech FT-6 printer has been running with Octoprint for 6 months or more. Zero problems. On Thursday I finished a print, shut down the system and went to bed. The next morning when I started the system Octoprint could not detect a serial port. It has not worked since.

Here is the message in Octoprint:
Changing monitoring state from "Offline" to "Detecting serial port"
Serial port list: []
Changing monitoring state from "Detecting serial port" to "Error: Failed to autodetect serial port, please set it manually."
Failed to autodetect serial port, please set it manually.

What did you already try to solve it?
Read through a number of similar issues and followed their solutions, nothing has helped. I tried 3 different cables, reloaded octoprint fresh, tried a different pi, updated to newest version of octoprint, reverted back to old version of octoprint, added specific serial ports in settings (/dev/ttyACA*,/dev/ttyACM*, etc.)

At this point I'm wondering if it's something wrong with the printer board and nothing with the pi or octoprint

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, what kind of hardware precisely, ...)

Octoprint version tried 1.3.12 and 1.4.2
Octopi version - Version 0.17.0
Pi - Raspberry Pi 3 Model B Rev 1.2 - also tried on a Pi 4
Printer is using an Big Tree Tech SKR v1.4

I'm not a linux expert but I can type stuff in when connected via ssh.

Hello @cyasgar!

To check the printer, try to connect with pronterface.
For it could be some serial issue, logs would be quite handy here.

I turned on the logging - I guess it was turned off. I don't have pronterface but will download and try it.

serial (1).log (752 Bytes)
octoprint.log (121.2 KB)

I tried pronterface and it can't seem to connect either. My PC acts like something was connected via USB (ding) but then pronterface can't see the printer. I'm stuck with assuming that something is wrong with the SKR v1.4 board. If you conclude anything else let me know otherwise I'll go down that rabbit hole.

A little more info in case anyone is watching this. I powered everything down and back up, disconnected and reconnedted, etc. and now I see COM3 in pronterface but I still can't connect. I cycled through all of the baud rates and get this message on each of them:
Connecting...
[ERROR] Could not connect to COM3 at baudrate 115200:
Serial error: could not open port 'COM3': WindowsError(2, 'The system cannot find the file specified.')

More info. I switched back to the pi 4 and this is now the error that I'm getting:
Changing monitoring state from "Offline" to "Detecting serial port"
Serial port list: ['/dev/ttyAMA0']
Connecting to: /dev/ttyAMA0
Changing monitoring state from "Detecting serial port" to "Opening serial port"
Connected to: Serial<id=0xb488e070, open=True>(port='/dev/ttyAMA0', baudrate=115200, bytesize=8, parity='N', stopbits=1, timeout=10.0, xonxoff=False, rtscts=False, dsrdtr=False), starting monitor
Starting baud rate detection...
Changing monitoring state from "Opening serial port" to "Detecting baudrate"
Trying baudrate: 115200
Could not write anything to the serial port in 5 tries, something appears to be wrong with the printer communication
Changing monitoring state from "Detecting baudrate" to "Offline (Error: Could not write to serial port)"
Connection closed, closing down monitor
Closing down send loop

For what it's worth, I figured this one out. Nothing wrong with Octoprint. It turns out the SKR v1.4 smoothie board I was using cut communication when there is a thermistor failure. So I replaced the thermistor on the hot end and all is good again.

1 Like