Octoprint no longer loading after plug-in addition

What is the problem?

I had a functioning Octoprint system (Octoprint 1.9.2 / OctoPi 1.0.0) running on a RPi 3b and I wanted to use it to reflash the firmware on my Ender 5 Plus that is messed up. So, I tried to install the plug-in for the Firmware Updater from the OctoPrint plug-in installer. After the plug-in install Octoprint quit working. When I try to connect to the ip address or (http://RPi3DPrinter.local) I get the page saying that OctoPrint is not running.

What did you already try to solve it?

I tried a rebooting the RPi and after it fully boots and I give it some time, I still get the same page. I tried all of the suggestions on that page

  1. The "ps -ef | grep -i octoprint | grep -i python" command give no return, so there is no python program running for OctoPrint.
  2. I looked at the OctoPrint log file:

octoprint.log (125.9 KB)

and do not see any errors that I would recognize as a problem.
3) I tried to start the service and then re-enter the ps command and again do not see any processes running.

I would appreciate any help anyone could provide.

Have you tried running in safe mode?

I have not tried this but don't see how it would do any good.

Did running in safe mode solve the problem?


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible
OctoPrint Version 1.9.2
OctoPi Version 1.0.0

On the command line, run

/home/jeff/oprint/bin/octoprint serve

and see what it prints out.

This is kinda ironic, given that safe mode explicitly disables third party plugins that might prevent the server from starting up.

Thanks for your reply. I ran the line you suggested and received the following error message:

2023-08-11 14:10:45,431 - octoprint.startup - CRITICAL - Could not initialize settings manager: Error parsing the configuration file /home/jeff/.octoprint/config.yaml, it is invalid YAML.
2023-08-11 14:10:45,431 - octoprint.startup - CRITICAL - There was a fatal error starting up OctoPrint.

So, looks like I need a replacement /home/jeff/.octoprint/config.yaml file. Can I just copy one from the web or do I need to do something else? The config.yaml file is here:
config.yaml (1.9 KB)

As for the question about not running in Safe Mode, I don't think it is that ironic. My understanding is that you run in Safe mode to allow you to add back the plug-ins one at a time until you find the one that is causing the problem. Here I had a working system and upon adding a specific plug-in it quit working. So, I already knew which plug-in was causing the problem. Or am I not understanding the use of Safe Mode?

Safe mode gives you the ability to remove the faulty plugin from the running system. And yes, it presupposes you know what the certain plugin is.

Okay, thanks. Good to know. Unfortunately, I don't have the knowledge on how to remove the defective plug-in even though I know which one it is. So, booting into Safe Mode would not have helped me much.

Is there a link I can look at to help me figure out how to remove the Firmware Updater plug-in or can the plug-in be repaired from a Safe Mode boot by replacing the defective config file?


You could try just renaming the config.yaml file, and then transfer settings from it to the newly created one that OctoPrint will generate on restart. It will be as if you just installed OctoPrint.

mv /home/jeff/.octoprint/config.yaml /home/jeff/.octoprint/config.bak

Actually looks like that config.yaml is completely corrupted. It's possible the SD card is in bad shape in general.

I looked at the file and found that you are correct. In looking at the .octoprint directory I saw that there was a a config.backup file. I copied that to config.yaml and was able to start up octoprint in safe mode. I then removed the firmware update plug-in and restarted octoprint normally. So, I'm back in business. Thanks!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.