Octoprint no longer starts and I don't know what to do

What is the problem?

Ever since late July 2022, I haven't been able to login to Octoprint. My server no longer starts even when I try sudo service octoprint start (or restart). I get the dreaded The OctoPrint server is currently not running error page

What did you already try to solve it?

I have tried looking at the logs to see if I can spot anything wrong (I don't). I have tried adding the safe mode flag to config.yaml and restarting the Raspberry Pi but it doesn't start in safe mode. It just behaves the same as before (server not running). I have tried updating my system packages with apt-get and it didn't help.

Have you tried running in safe mode?

Yes, I tried running in safe mode by adding the flag to config.yaml but when I restarted, it didn't load in safe mode.

Did running in safe mode solve the problem?

No

Systeminfo Bundle

I am unable to create a systeminfo bundle because I cannot access the UI. From the command line when I try octoprint systeminfo . I get a command not found.

I will manually attach all the octoprint and octopi logs in the respective folders here.
octopi_logs.zip (294.6 KB)
octoprint_logs.zip (296.0 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

I am using a Raspberry Pi 3 Wifi and installed Octoprint using the OctoPi image. I have been using it for years connected to my Prusa MK3S via USB. Everything was working fine until this summer when it stopped working one day. I am not sure if this is related to the Python 3 requirement/upgrade? I've looked inside octoprint.log but the last entry was from July 2022 and it doesn't log anything from any attempts to start the server since.

I am fairly computer literate and am happy to wipe everything and start all over but I'd like to save as many settings or configurations as possible since it took me a long time to setup. If this is not possible, I'll reimage and start from scratch.

model: Raspberry Pi 3 Model B Plus Rev 1.3
octoprint: 1.6.1
octopi_version: 0.16.0
python: 2.7.13

Thanks for your help!

that octopi version is fairly old but the python 3 requirements are not part of the issue. without updates logs it won't be much help. almost sounds like SD card corruption and the fastest way back would be to re-flash the SD card with the latest version.

1 Like

can't remember with that version of OctoPrint if backup plugin existed, but there is a manual process you could try. you just need to transfer the /home/pi/.octoprint/ folder off of the SD card with winscp or FileZilla using SSH connection. That will get all your plugin settings and data, OctoPrint settings. However you will still have to reinstall your plugins.

Hi, thanks for replying. I included the entire contents of the octoprint and octopi logs specified in the help article. What are the "updates" logs? If you tell me where to find them, I am happy to attach them to this ticket. Also, will there be any potential conflicts with backing up /home/pi/.octoprint which has settings for this (old) version and restoring it over a fresh install and fresh (new versioned) plugins? If that is the official way to backup (sans GUI access), I am happy to try it. I'll wait to hear back from you/others.

Sorry, that sentence wasn't clear. What I meant was if there wasn't anything updated in the log since July there's not going to be anything in there to tell you why it's not starting. You could try to manually start the executable and see if it spits out any usable errors.

/home/pi/oprint/bin/octoprint serve --debug