Octoprint Not detecting my 3d printers USB connection

What is the problem?

I have set everything out properly, but octopprint just can’t detect a serial port

What did you already try to solve it?

I have tried adding the code to the additional serial ports box, it shows up, i can click on it, but an error message pops up when I connect it

Have you tried running in safe mode?

I have not ran in it safe mode but I do not think it would work anyways, i suspect it has something to do with my 3d printers firmware.

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

I have installed all the newest octoprint and octopi versions, i have a rasberry pi 4B, my printer is the ELEGOO Neptune 4 pro, it runs Klipper firmware. Could it have anything to do with klipper?

Hello @Mr_Burge !

So, do you have Klipper installed on your Pi too?

1 Like

Maybe a silly question.
Does your cable compatible data ?

No, I do not have klipper installed on my PI, my 3d printer comes with klipper pre-installed, would installing the octoklipper solve my problems?

yes it does, when i bought it I made sure not to make that mistake

1 Like

Now for clarification:

You got a printer with Klipper on it but without a Pi that you got yourself? Or is there a Pi like SBC with that printer that runs the Klipper host?

The Neptune 4 Pro has it's own Klipper Ecosystem with Fluidd. There is no need for OctoPrint.

BTW: Klipper is a two part firmware solution. It works different than Marlin:

oohhh, ok thanks for that, i understand now.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.