Octoprint not loading on Prusa mini

I have installed latest Octorprint on SDcard on PaspberryP1 3 B+ connected to Prusa Mini+

I can access http://192.168.0.37/#control and even see my webcam.

But Octoprint does not load on the Prusa mini screen. Also when using Prusas Slicer and sending file to print I get error : http://192.168.0.37/api/files/local (192.168.0.37) ERROR

Would be most grateful for any help in solving this.

Is that a feature of the Prusa mini?

Just error doesn't tell us much - but check out this post in case you have bgcode enabled

Thank you very much. I had everything working fine until updating slicer and then also reinstalling Octoprint with newer image.

Yes on mini display the Octoprint interface (rather than the default Prusa mini interface) should be displaying, (or at least it did in the past while it still worked until update).

I have now been on the web and then unticked in Slicer the "supports binary G-code" and now when in Slicer "upload to printer and print" I get a new slicer message saying "COMPLETED" but nothing prints.

I have also in added the bgcode/ plugin, but no printing happens, even though Slider message says the file uploads and prints to printer

Thank you for link, but the Prusa write-up didn't solve it.

Another notable issue: I can connect to Octoprint (no wired connection, I have WIFI) in browser http://192.168.0.37/#control, but not with http://octopi.local/

I think the problem remains that Octoprint interface does not load to Prusa Mini display panel.

Hi, It is now working.
The problem was that in Slicer I had not added a printer but had used the default just as it was on the Octoprint image.
Also in Slicer, Configuration/Preferences/other I have unticked "use binary G-code when the printer supports it.
Also I added the b-code plugin to Octoprint

The last issue that remains for now is that with browser I can not log in Octoprint with http://octopi.local/ but I can with http://192.168.0.37/#control.

Finally I should add that Octoprint interface comes up on Prusa display panel when a printing job is being uploaded. Apologies that I had forgotten this default behaviour on Prusa mini display panel

Thank you so very much for your great support.

Can you please explain this line?

It is still the same thread and it is just 4 hours later...

Hi Edward,

The line " Continuing the discussion from [Octoprint not loading on Prusa mini] was auto inserted. I am new to this forum and when typing my initial reply there were 2 options above the text I was typing , but the < reply > button was not visible as I had not exited the allow cookies confirmation. So simply ignore the line, all it means is that the full threat can be viewed above. Hope this clarifies. PS: I have now edited that message and deleted the confusing text