Octoprint not running after update 1.10.0

What is the problem?

I updated to the newest version of Octoprint and now it won't run anymore

What did you already try to solve it?

I reinstalled the update, which showed some errors that I didn't understand. I also updated the pip since I got an error saying this was a problem for two plugins. I have screen shots but can't post more than one of them as a new user.

Have you tried running in safe mode?

I can't get it to run in safe mode. I'm not good at python and can't figure out how to get it to do that.

Did running in safe mode solve the problem?


Systeminfo Bundle

I tried to get the system info bundle through the terminal and got a "command not found" error. I'm guessing I did it wrong but don't know what to do differently.

Additional information about your setup

Upgraded to Octopi 1.10.0, Ender 3 Pro, Marlin firmware, Chrome, and windows 10.

I was able to figure out how to get the log file.
octoprint.log (244.1 KB)

I'm really at a loss for what to do, I'm not very knowledgeable on programming so this is all foreign to me. If there's any more info I can give let me know and thanks in advance for any help!


same here ! Octopi is starting into " The OctoPrint server is currently not running"
I tried to restart and update everything but still not working !
What can I (we) do !?

1 Like

"same here" isn't very useful to us. I highly doubt that both of you have identical hardware configurations with identical software configurations. The more details you can provide, the better chance we have of helping you solve the issue. A separate "Get Help" topic with as much of the template filled out would be even better.


So according to the octoprint.log file that you've posted, OctoPrint 1.10.0 seems to be running. It also looks like there are some connection attempts being made - they're logged as new clients connecting to the server. I get the feeling however that these connection attempts might not be successful, as you keep restarting the server with no actual actions being taken in between.

When you try and access OctoPrint, do you get any errors in your browser? You can use SSH to access the Pi - do you know it's IP address for that and is that the same as what you used to access OctoPrint?

It looks like you've tried to install the update from the command line, but OctoPrint's virtual environment (the Python environment where it lives, separate from the system-level one) is not activated in the screenshot you've posted. This won't help, but hopefully won't hinder your progress trying to get the issue fixed - but it will not work properly trying to do it that way. You've effectively installed OctoPrint again, in a separate location.

1 Like

Hi there! Thanks for trying to help, I appreciate it.
When I try to get to Octoprint I get the " The OctoPrint server is currently not running" error page. I used the SSH to get into the Pi and get the octoprint log. I did notice in all this that when I installed the update my router seemed to change the IP address of the pi, but I changed to to what my router had it as for the SSH and was able to use that to get in, and when I use the new IP address to try and get to octoprint I still get the same error.

Ah, ok. I didn't know it wouldn't work that way. I did use the command line. Is this something I should undo or just something that will be running in the background and not cause any problems?

Hi, you are totally right. I was just sad and thought it will be an overall problem because of the update !
I started the update in the GUI from Octoprint.
Unfortunatly it says access denied when I try to get the log with "~/.octoprint/logs/octoprint.log" over putty. But I can go with SSH into Octopi. So do I just have to reinstall it ?

Thank you

Do you have any idea how long it will be before your problem is resolved if you fail to provide any useful information? At this point, I recommend you start over by flashing a new OctoPi image, use the username of "pi" and a password of your choosing. Then open a new Get Help topic and fill out the template completely.

We will attempt to help you resolve your problem in that topic.

1 Like

Hey all, still looking for help on this. Any ideas?

In case anyone else has this issue, I tracked it down to being BedLevel Visualiser. I completely reinstalled octoprint and then was putting all my plugins back on and when I put that one in it crashed just like before. I got help on the discord of how to start in safe mode and then removed that and it worked again. No idea what's going on with that plug in but it was what was ruining my octoprint.

1 Like