Octoprint not running, including log file


#1

octoprint.log (21.3 KB)<a

I did not make any changes or updates, I wanted to sign up and found that it did not work

https://octoprint.juricekpavel.net/

after restarting to safe mode already works resolved thank you

accessControl:
 
appearance:
  defaultLanguage: cs
feature:
  legacyPluginAssets: true
plugins:
  announcements:
    _config_version: 1
    channels:
      _blog:
        read_until: 1529054100
      _important:
        read_until: 1521111600
      _octopi:
        read_until: 1527588900
      _plugins:
        read_until: 1529280000
      _releases:
        read_until: 1529502000
cura:
    cura_engine: /usr/bin/CuraEngine
    debug_logging: true
discovery:
    upnpUuid: e14058fd-fa14-454e-a3bb-4d49b2dfaf05
multicam:
    _config_version: 1
    multicam_profiles:
    - URL: https://octoprint.juricekpavel.net/w-otoc.cgi
      isButtonEnabled: false
      name: otoc1
    - URL: https://octoprint.juricekpavel.net/w-a1.cgi
      isButtonEnabled: true
      name: axis1
    - URL: https://octoprint.juricekpavel.net/w-a2.cgi
      isButtonEnabled: true
      name: axis2
pluginmanager:
    pip_force_user: true
softwareupdate:
    _config_version: 6
    check_providers:
      cost: cost
multicam: multicam
navbartemp: navbartemp
printerProfiles:
  default: _default
serial:
  autoconnect: true
  baudrate: 115200
server:
commands:
    serverRestartCommand: sudo service octoprint restart
    systemRestartCommand: sudo shutdown -r now
    systemShutdownCommand: sudo shutdown -h now
firstRun: false
onlineCheck:
    enabled: true
pluginBlacklist:
    enabled: true

seenWizards:
corewizard: 3
cura: null
temperature:
  profiles:
  - bed: 100
    extruder: 210
    name: ABS
  - bed: 60
    extruder: 180
    name: PLA
  - bed: '75'
    extruder: '220'
    name: PetG
system:
  actions:
  - action: pon
    command: printer_on.sh
    name: TiskarnaOn
  - action: poff
    command: printer_off.sh
    confirm: Opravdu chcete tiskarnu vypnout?
    name: TiskarnaOff
  - action: lon
    command: light_on.sh
    name: SvetloOn
  - action: loff
    command: light_off.sh
    event: PrintDone
    name: SvetloOff
  - action: l1on
    command: light1_on.sh
    name: Svetlo1On
  - action: loff
    command: light1_off.sh
    event: PrintDone
    name: Svetlo1Off
  - action: vent
    command: vent_on.sh
    confirm: Opravdu chcete ventilator zapnout?
    name: VentilatorOn
  - action: loff
    command: vent_off.sh
    confirm: Opravdu chcete ventilator vypnout?
    event: PrintDone
    name: VentilatorOff
webcam:
  stream: https://octoprint.juricekpavel.net/w-otoc.cgi
! $  root@3dtisk  ~  service octoprint status
● octoprint.service - OctoPrint
   Loaded: loaded (/etc/systemd/system/octoprint.service; enabled; vendor preset
   Active: failed (Result: exit-code) since Sat 2018-07-07 00:36:19 CEST; 25s ag
  Process: 1791 ExecStart=/home/octoprint/OctoPrint/venv/bin/octoprint serve --h
 Main PID: 1791 (code=exited, status=1/FAILURE)

čec 07 00:36:19 3dtisk systemd[1]: octoprint.service: Service hold-off time over
čec 07 00:36:19 3dtisk systemd[1]: octoprint.service: Scheduled restart job, res
čec 07 00:36:19 3dtisk systemd[1]: Stopped OctoPrint.
čec 07 00:36:19 3dtisk systemd[1]: octoprint.service: Start request repeated too
čec 07 00:36:19 3dtisk systemd[1]: octoprint.service: Failed with result 'exit-c
čec 07 00:36:19 3dtisk systemd[1]: Failed to start OctoPrint.
lines 1-12/12 (END)⏎  

#2

Did you change your settings, or directly edit the config.yaml file recently? Share the entire config file, the only entries you need to remove are secret key, api key, etc.

    self._mark_read_until(channel, until)
  File "/home/octoprint/OctoPrint/venv/lib/python2.7/site-packages/octoprint/plugins/announcements/__init__.py", line 241, in _mark_read_until
    self._settings.set(["channels", channel, "read_until"], until, defaults=defaults)
  File "/home/octoprint/OctoPrint/venv/local/lib/python2.7/site-packages/octoprint/plugin/__init__.py", line 514, in _func
    return orig_func(*args_mapper(args), **kwargs_mapper(kwargs))
  File "/home/octoprint/OctoPrint/venv/local/lib/python2.7/site-packages/octoprint/settings.py", line 1517, in set
    self.load()
  File "/home/octoprint/OctoPrint/venv/local/lib/python2.7/site-packages/octoprint/settings.py", line 865, in load
    column=column)
InvalidSettings

#3

config.yaml (2.4 KB)

 root@3dtisk  ~  service octoprint status
● octoprint.service - OctoPrint
Loaded: loaded (/etc/systemd/system/octoprint.service; enabled; vendor preset
Active: failed (Result: exit-code) since Sat 2018-07-07 00:36:19 CEST; 25s ag
Process: 1791 ExecStart=/home/octoprint/OctoPrint/venv/bin/octoprint serve --h
Main PID: 1791 (code=exited, status=1/FAILURE)

čec 07 00:36:19 3dtisk systemd[1]: octoprint.service: Service hold-off time over
čec 07 00:36:19 3dtisk systemd[1]: octoprint.service: Scheduled restart job, res
čec 07 00:36:19 3dtisk systemd[1]: Stopped OctoPrint.
čec 07 00:36:19 3dtisk systemd[1]: octoprint.service: Start request repeated too
čec 07 00:36:19 3dtisk systemd[1]: octoprint.service: Failed with result 'exit-c
čec 07 00:36:19 3dtisk systemd[1]: Failed to start OctoPrint.
lines 1-12/12 (END)⏎


#4

Is it really that hard to write a line or two "yes I modified the config file" or no "I did not modify it by hand" so that someone who would like to help you not have to guess what the cause could be?

Nevertheless, your config.yaml is broken, it contains several lines with a wrong line indentation.


#5

I wrote that I did not change anything, every time I was upgraded


#6

Share the config file, please.