Octoprint not starting up

What is the problem?
On multiple occasions my octoprint would just hang at the " The OctoPrint server is currently not running" screen and following the steps provided on there it wouldn't fix, usually I would just format the SD and reinstall octoprint, but i'm getting tired of doing this so i'm trying to see if there is a solution to this so if it happens again I can fix it.
What did you already try to solve it?
I've tried the suggested things to do on the " The OctoPrint server is currently not running" page, restarted the raspberry pi multiple times, tried restarting services and nothing fixes.

Logs (octoprint.log, serial.log or output on terminal tab, browser error console ...)
https://pastebin.com/4Y9YntWS this is octoprint.log

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ...)

Octopi Version : 0.16.0
Raspberry Pi 3 Model B

Would you happen to have the habit of simply unplugging the power on the Pi without properly shutting it down first? If so, stop doing that, it can corrupt the file system and break things in various ways, including breaking OctoPrint completely.


It's probably worth trying this in Safe Mode to see if it will come back to life.