Octoprint Not Working Just Getting Communication Error

What is the problem?
Everytime I load into my octoprint interface on my browser I can connect just fine to the printer I can see the webcam interface no problems, but when i try to do anything, change the temperature, move the ectruder or start a print I just get the red box error on the right hand side of the browser whicg says.

" Communication error
There was a communication error while talking to your printer. Please consult the terminal output and octoprint.log for details. Error: Too many consecutive timeouts, printer still connected and alive?"

What did you already try to solve it?
I tried a complete reinstall multiple times, I have tried using an ethernet instead of wifi and tried a new power cable, i currently am using a 5V 3A micro usb charger with on and off power switch which states on amazon it is dor rassberry pu models B+ which is the model I have


Changing monitoring state from "Offline" to "Detecting serial port"
Serial port list: ['/dev/ttyUSB0']
Connecting to: /dev/ttyUSB0
Changing monitoring state from "Detecting serial port" to "Opening serial port"
Connected to: Serial<id=0x763435d0, open=True>(port='/dev/ttyUSB0', baudrate=115200, bytesize=8, parity='N', stopbits=1, timeout=10.0, xonxoff=False, rtscts=False, dsrdtr=False), starting monitor
Starting baud rate detection...
Changing monitoring state from "Opening serial port" to "Detecting baudrate"
Trying baudrate: 115200
Recv: Test my message
Send: N0 M110 N0*125
Recv: echo: External Reset
Recv: 1.0.0
Recv: echo:(none, default config)
Recv: Dec 27 2018
Recv: echo:10075echo:Hardcoded Default Settings Loaded
Recv: echo:Steps per unit:
Recv: echo:  M92 X80.00 Y80.00 Z400.00 E93.00echo:Maximum feedrates (mm/s):
Recv: echo:  M203 X500.00 Y500.00 Z5.00 E25.00echo:Maximum Acceleration (mm/s2):
Recv: echo:  M201 X500 Y500 Z100 E5000echo:Acceleration: S=acceleration, T=retract acceleration
Recv: echo:  M204 S500.00 T500.00echo:Advanced variables: S=Min feedrate (mm/s), T=Min travel feedrate (mm/s), B=minimum segment time (ms), X=maximum XY jerk (mm/s),  Z=maximum Z jerk (mm/s),  E=maximum E jerk (mm/s)
Recv: echo:  M205 S0.00 T0.00 B20000 X20.00 Z0.40 E5.00echo:Home offset (mm):
Recv: echo:  M206 X0.00 Y0.00 Z0.00echo:PID settings:
Recv: echo:   M301 P21.73 I1.54 D76.55echo:SD init fail
Recv: echo:SD init fail
Recv: ok
Changing monitoring state from "Detecting baudrate" to "Operational"
Send: N0 M110 N0*125
Recv: ok
Send: N1 M115*39
Recv: FIRMWARE_NAME:Marlin V1; Sprinter/grbl mashup for gen6 FIRMWARE_URL:http://www.mendel-parts.com PROTOCOL_VERSION:1.0 MACHINE_TYPE:CTC 3D EXTRUDER_COUNT:1 UUID:00000000-0000-0000-0000-000000000000
Recv: ok
Send: M21
Recv: echo:SD init fail
Recv: ok
Changing monitoring state from "Operational" to "Starting"
Send: N0 M110 N0*125
Recv: ok
Changing monitoring state from "Starting" to "Printing"
Send: N1 M190 S45*88
Recv: T:17.46 E:0 B:17.7T:17.50 E:0 B:18.1T:17.42 E:0 B:18.1T:17.50 E:0 B:18.7T:17.50 E:0 B:19.4T:17.46 E:0 B:20.0T:17.42 E:0 B:20.6T:17.50 E:0 B:21.8T:17.50 E:0 B:22.5T:17.46 E:0 B:23.1T:17.46 E:0 B:24.4T:17.50 E:0 B:25.0T:17.42 E:0 B:25.5T:17.50 E:0 B:26.4T:17.50 E:0 B:26.8T:17.50 E:0 B:27.5T:17.50 E:0 B:28.2T:17.50 E:0 B:28.9T:17.46 E:0 B:29.5T:17.46 E:0 B:30.0T:17.50 E:0 B:30.8T:17.46 E:0 B:31.2T:17.50 E:0 B:32.1T:17.50 E:0 B:32.5T:17.50 E:0 B:33.3T:17.46 E:0 B:33.7T:17.50 E:0 B:34.6T:17.46 E:0 B:35.1T:17.50 E:0 B:35.7T:17.50 E:0 B:36.2T:17.50 E:0 B:36.7T:17.50 E:0 B:37.2T:17.46 E:0 B:37.7T:17.50 E:0 B:38.3T:17.50 E:0 B:38.7T:17.50 E:0 B:39.3T:17.50 E:0 B:39.7T:17.50 E:0 B:40.3T:17.50 E:0 B:40.6T:17.46 E:0 B:41.2T:17.46 E:0 B:41.8T:17.50 E:0 B:42.1T:17.50 E:0 B:42.6T:17.46 E:0 B:42.9T:17.50 E:0 B:43.5T:17.50 E:0 B:43.8T:17.42 E:0 B:44.4T:17.46 E:0 B:44.7ok
No response from printer after 6 consecutive communication timeouts, considering it dead. Configure long running commands or increase communication timeout if that happens regularly on specific commands or long moves.
Changing monitoring state from "Printing" to "Offline (Error: Too many consecutive timeouts, printer still connected and alive?)"
Connection closed, closing down monitor

Additional information about your setup

PI Model B+
Ender 3 Mostly stock

This should not all be on one line but on several. Your printer's firmware is buggy and not confirming to the communication standard. I suggest you look if there's an updated version, or a downgrade that is known to work and complain to your printer vendor in any case.

is there an easy way to do this? Without havinf to use jumper cables ect is it possible to do using the pi?

I don't have personal experience with your particular printer and thus cannot tell you.

The easiest way for me was to switch to stock marlin with the ender 3 example config with some minor edits :slight_smile:

1 Like