Octoprint now Offline, stopped connecting to printer

What is the problem?

Hello! Octoprint will not connect to printer. It says "Offline (Error see octoprint log file for details). Webcam is not working either. Octoprint has been working fine since install about 6 months ago. I can ssh to the RPi with no issues.

What did you already try to solve it?

Set baud rate and Serial port to Auto. Disabled plugins.

Have you tried running in safe mode?

Yes, but it would not work. Error saying that Safe Mode could not be executed.

Did running in safe mode solve the problem?


Complete Logs

octoprint.log (2.0 MB)


Additional information about your setup

Octopriint 1.5.2, Qidi X-Plus printer, RPi 3B+ connected to printer main board using UART connection. Windows 10 PC using IE browser.


Have you tried without webcam connected?

Do you regularly power off the Pi? If yes, how?

@Ewald_Ikemann Thanks for the comment! Yes I've tried without the webcam but no change. I did get Octoprint to finally connect. I rebooted the server and then rebooted the RPi. I had to choose Auto for the serial port and baudrate.

No I do not regularly power off the RPi and leave it going most of the time. I will do that from time to time now. How do you suggest the best way to power off the RPi?

1 Like

Before power off always shutdown from the option in the navbar. Then take the power down.
Else you may get issues with a broken file sytstem on the SD card.


@Ewald_Ikemann Will do thanks!