Octoprint/OctoPi : space issues

What is the problem?

Not really a "problem", per se. More like proactive maintenance.

Space on OctoPi was filling up. What I would like to know, RE: OCTOPI . ... there is a directory on the Pi labelled /docs Is that just user documentation, and would it be safe to delete? I gained about 475Mb of space cleaning of extra stuff yesterday, and noticed when I ran >>sudo ncdu that there was a lot of space taken up in the /docs folder. If I don't need that, I would just delete it...

The other thing I don't quite understand is why I'm bumping into space limits on a 64Gb SD card. It looks like only a couple Gb are being used. Maybe that's a different question, but maybe there's a way to modify the partition on the SD card to have more use of the free space? I don't keep stuff on the Pi at all. Once I'm done with it (gcode, stills, etc) it gets moved off.


What did you already try to solve it?

Investigate and delete filed

Have you tried running in safe mode?

Not applicable, but yes.

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

Not at home at the moment to provide bundle

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

1.8.7 (just updated last night)
Ender 5S, V1.1.6.7
R-Pi 3B w/ 64gb SD card

Try sudo ncdu /
That shows you the usage of the whole partition

1 Like

Yes, thanks I did that, I was typing from memory. My Linux is pretty rusty, not sure if there is a way to extend or increase the size of the partition....

Usually that's done on first boot in the background

What does df -h output?

I'll have to get back to you on that one - I'm at work. I do recall it shows a partition size of 2.4Gb, and my initial issue was that I only had <100Mb available. I've go that up to ~500Mb or so, which is usable, but I have way more space on the card available....

If your partition size wasn't showing the full available space of the SD card you probably need to use raspi-config to extend the filesystem.

1 Like

Exactly. This is just what I was looking for thanks.

Just wanted to follow up on this. Ran sudo raspi-config and expanded the file system... 58.3Gb total, 54Gb available. I don't think I'm gonna hit a limit any time soon... Thanks :+1: :+1:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.