Octoprint/Octoscreen Touch not working

Installed a fresh new Octoprint using the Raspberry Pi Imager - OctoPi 1.0.0 and OctoPrint 1.9.0, all successfully. Added my 7 Inch Raspberry pi screen, installed Octoscreen. Screen works, I can see output etc, but Touch does not work.

I then flashed a new Raspian SD card and installed that to check that screen and touch work as expected and they do. Go back to Octoprint SD card and screen output works but touch does not.

I have tried searching for the Raspberry Pi 7Inch Touchscreen driver but can't seem to find any.

Another forum suggests that this is a known issue with Bullseye but I don't believe that since the Raspian SD card works ok and that is Bullseye.

Any ideas?

1 Like

Add this to your config.txt...


I have 2 OctoPi and it happened on both. Once I added that both worked (Pi 3b+ and Pi 4 8gb).

Genius. Thank you. Spent a week on this.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.