Octoprint on a Flashforge Creator Max 2 from a Windows 10 computer

What is the problem?

octoprint-systeminfo-20221123223708.zip (32.7 KB)

Hello All,
I am trying to get OctoPrint running on a FlashForge Creator Max 2 from a windows desktop computer. Ive got Octoprint running fine from what I can tell and all other functions (stuff like webcam and timelapse) seem to work normally except for the connection with the printer. From my understanding octoprint needs some help talking to FlashForge printers so I am using the FlashForge Plugin to try and get it to connect (GitHub - Mrnt/OctoPrint-FlashForge: OctoPrint plugin to support closed source printers from FlashForge, PowerSpec, Dremel). Using this software, it seems that Octoprint can see my printer where it wasn't able to before but now I've run into a permissions problem which is pasted below (hopefully that was ok to do).

Unable to connect to FlashForge printer - permission error.

If you are using OctoPi/Linux add permission to access this device by editing file:

/etc/udev/rules.d/99-octoprint.rules

and adding the line:

SUBSYSTEM=="usb", ATTR{idVendor}=="2b71", MODE="0666"

You can do this as follows:

  1. Connect to your OctoPi/Octoprint device using ssh

  2. Type the following to open a text editor:

sudo nano /etc/udev/rules.d/99-octoprint.rules

  1. Add the following line:

SUBSYSTEM=="usb", ATTR{idVendor}=="2b71", MODE="0666"

  1. Save the file and close the editor

  2. Verify the file permissions are set to "rw-r--r--" by typing:

ls -al /etc/udev/rules.d/99-octoprint.rules

  1. Reboot your system for the rule to take effect.

The main thing I'm having trouble with is that everyone who has ran into this seems to be running on a raspberry pi/Linux and I am trying to run this on Windows 10 desktop rather than a raspberry pi and I'm not really familiar with Linux so I'm not sure what the equivalent actions are if that makes sense. I'm pretty lost as to where or how I can change the permissions/rules in the same way as instructed above. I cant find a folder/file that seems to contain the rules set for Octoprint from where I've installed it but I could just be blind.

So does anyone know where I might find these files or some way to edit these permissions in windows?

Here is another thread of this same issue in case it is helpful
(Flash-forge dreamer (dual extruder) issues connecting! Β· Issue #65 Β· Mrnt/OctoPrint-FlashForge Β· GitHub)

Have you tried running in safe mode?

Yes

Did running in safe mode solve the problem?

No, the output errors were different however as octoprint seemed to not see the serial port at all.

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

Uploaded the Zip file here, hopefully that's ok.

Additional information about your setup

OctoPrint version , OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

I am running on OctoPrint 1.8.6 using Windows 10 and Chrome as the browser. I am not using a PI or any other similar computer, I am trying to get this to function from a desktop computer. The printer in question is the FlashForge Creator Max 2.

Hello @SendHelp !

Do you have something like Cura or Pronterface running on the PC when you try to connect the printer via OctoPrint?

1 Like

I have only been running FlashPrint alongside it, I haven't had much luck getting Cura to run with this printer in general but I also haven't spend a ton of time on that yet. I have not used Pronterface before.
Thanks!

Then disable/turn off FlashPrint and try to connect again with OctoPrint.

This is what it spat out for me this time. Did I miss a step that configures the com port possibly?

2022-11-24 17:19:15,203 - octoprint.plugins.flashforge - INFO - Found a FlashForge FlashForge Creator Max 2 3D Printer, port:2:10
2022-11-24 17:19:15,283 - octoprint.util.comm - INFO - Changing monitoring state from "Offline" to "Detecting serial connection"
2022-11-24 17:19:16,640 - octoprint.plugins.flashforge - INFO - Found a FlashForge FlashForge Creator Max 2 3D Printer, port:2:10
2022-11-24 17:19:16,656 - octoprint.plugins.flashforge - INFO - Found a FlashForge FlashForge Creator Max 2 3D Printer, port:2:10
2022-11-24 17:19:16,703 - octoprint.util.comm - INFO - Serial detection: Performing autodetection with 4 port/baudrate candidates: COM1@115200, COM1@250000, FlashForge Creator Max 2 3D Printer, port:2:10@115200, FlashForge Creator Max 2 3D Printer, port:2:10@250000
2022-11-24 17:19:16,703 - octoprint.util.comm - INFO - Serial detection: Trying port COM1, baudrate 115200
2022-11-24 17:19:16,703 - octoprint.util.comm - INFO - Connecting to port COM1, baudrate 115200
2022-11-24 17:19:16,740 - octoprint.plugins.softwareupdate - INFO - Fetching check overlays from https://plugins.octoprint.org/update_check_overlay.json
2022-11-24 17:19:16,742 - octoprint.util.comm - INFO - Serial detection: Handshake attempt #1 with timeout 2.0s
2022-11-24 17:19:16,743 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0
2022-11-24 17:19:18,758 - octoprint.util.comm - INFO - Serial detection: Handshake attempt #2 with timeout 2.0s
2022-11-24 17:19:18,758 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0
2022-11-24 17:19:18,779 - octoprint.plugins.flashforge - INFO - Found a FlashForge FlashForge Creator Max 2 3D Printer, port:2:10
2022-11-24 17:19:20,768 - octoprint.util.comm - INFO - Serial detection: Handshake attempt #3 with timeout 2.0s
2022-11-24 17:19:20,769 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0
2022-11-24 17:19:22,781 - octoprint.util.comm - INFO - Serial detection: Trying port COM1, baudrate 250000
2022-11-24 17:19:22,782 - octoprint.util.comm - ERROR - Unexpected error while setting baudrate 250000
Traceback (most recent call last):
  File "C:\OctoPrint\venv\lib\site-packages\octoprint\util\comm.py", line 3380, in _perform_detection_step
    self._serial.baudrate = b
  File "C:\OctoPrint\venv\lib\site-packages\serial\serialutil.py", line 299, in baudrate
    self._reconfigure_port()
  File "C:\OctoPrint\venv\lib\site-packages\serial\serialwin32.py", line 222, in _reconfigure_port
    raise SerialException(
serial.serialutil.SerialException: Cannot configure port, something went wrong. Original message: OSError(22, 'The parameter is incorrect.', None, 87)
2022-11-24 17:19:22,783 - octoprint.util.comm - INFO - Serial detection: Trying port FlashForge Creator Max 2 3D Printer, port:2:10, baudrate 115200
2022-11-24 17:19:24,123 - octoprint.util.comm - INFO - Serial detection: Handshake attempt #1 with timeout 2.0s
2022-11-24 17:19:26,134 - octoprint.util.comm - INFO - Serial detection: Handshake attempt #2 with timeout 2.0s
2022-11-24 17:19:28,146 - octoprint.util.comm - INFO - Serial detection: Handshake attempt #3 with timeout 2.0s
2022-11-24 17:19:30,160 - octoprint.util.comm - INFO - Serial detection: Trying port FlashForge Creator Max 2 3D Printer, port:2:10, baudrate 250000
2022-11-24 17:19:30,160 - octoprint.util.comm - INFO - Serial detection: Handshake attempt #1 with timeout 2.0s
2022-11-24 17:19:32,172 - octoprint.util.comm - INFO - Serial detection: Handshake attempt #2 with timeout 2.0s
2022-11-24 17:19:34,181 - octoprint.util.comm - INFO - Serial detection: Handshake attempt #3 with timeout 2.0s
2022-11-24 17:19:36,191 - octoprint.util.comm - INFO - Changing monitoring state from "Detecting serial connection" to "Error"
2022-11-24 17:19:36,662 - octoprint.plugins.tracking - INFO - Sent tracking event commerror_autodetect, payload: {'commerror_text': 'No more candidates to test, and no working port/baudrate combination detected.'}
2022-11-24 17:19:39,350 - octoprint.util.comm - INFO - Changing monitoring state from "Error" to "Offline after error"
2022-11-24 17:19:39,353 - octoprint.plugins.action_command_notification - INFO - Notifications cleared
2022-11-24 17:19:40,713 - octoprint.plugins.flashforge - INFO - Found a FlashForge FlashForge Creator Max 2 3D Printer, port:2:10

Also thanks for helping me out, especially on Thanksgiving!