Octoprint on a pi4 8gb

Initial testing results were positive, but required a little manual updating in ssh and caused some path related changes to happen. Weezl is definitely on his game getting this working as close to possible to existing octopi images relative to initial configuration via txt files, etc. Definitely rapid development when he doesn't even have a 8GB model available. Definitely will require some beta testers here, since my testing was on a 3B and soon my 4GB pi4.


great news, if you need testers, my PI 4 8GB, my old PI B + and my ender 3 pro, its at your disposal.
jI haven't used Octopi yet, I was planning to put it on the PI4 8go.
Very good day.

Alright release time :smiley:

Let me start with a :warning: warning :warning: :
This OctoPi image is based on the latest 64 bit Raspberry Pi OS (formerly raspbian) beta.
The image can be found here

Beta means that there are and probably will be bugs for some time.
We did for example encounter a problem with the kernel in this image and the Pi 3B - the Pi was running unstable and displayed undervoltage warnings. After updating the kernel (with apt upgrade) it worked much better and it seemed to be stable again.

Let's get back to the OctoPi image.
It was build with @guysoft s scripts (Octopi and CustomPiOS) on a Raspberry Pi 3B+.
Because of the processor's architecture the image works only on Pi 3B, Pi 3A+, Pi 3B+ and Pi 4B.

What did I change?
I added buster-backports to the apt sources of the base image because of a dependency of the scripts.
Then I removed the cura-engine from the script (also because of a dependency problem). So if you want to use it you have to add it yourself for now.

And here it is :slight_smile:

9b6d9eb5a908be8a945995fdbbbee115  OctoPI64-0.18.0-beta.img
a7113c0c1deee63ab21038155d65e07f  OctoPI64-0.18.0-beta.zip

md5 checksums

I strongly suggest you update your image after flashing with sudo apt update && sudo apt -y upgrade via ssh or the console on a display.

Big thanks to @jneilliii who supported me while building the image and helped me testing it :heart:

If the testing works out well I will make a separate post for it.

Happy testing :slight_smile:


I'm downloading and testing it tonight.
You are great.

:+1: :+1: :+1: :+1: :+1:

1 Like

It's ok for the boot very quickly

Version Octoprint 1.4.0

The Raspberry Pi NoiR Camera V2 does not work :thinking:

at boot, the connection is not made with the printer, I made connected and it works

I'm having issues with prints never starting. I've tracked it down to be Octolapse I believe, so I will follow up with them if I find more, but I figured I would let y'all know. Very happy so far otherwise!

I'll look into it.
I didn't test the cam on a Pi 4 - just on a Pi 3+.

I am interested in testing it. I had planned on loading a 32 bit image on mine and upgrade when the 64 bit image was available. I downloaded and will test soon.

First impression with timelapse :face_with_monocle:

Cura announces 43 min
The connection to the printer works automatically 1 in 2 times, I will monitor to be more precise.
The Gcode viewer works fine but a little late,
Temperature: OK
I installed the Dashboard plugin, it works very well.
Test on 2 USB cameras: OK
The raspberry camera doesn't work

Timelapse of 10 s Ok, adjustments remain to be made but no other problem.
45 min print

The rest of my contastations :

The plugins work for now:
Dashboard : Ok
DisplayLayerProgress Plugin OK
Fullscreen Plugin OK
SimpleEmergencyStop OK
The 8GB boot is very fast
Orders are applied instantly.
The video is beautiful and fluid.

:clap: :clap: :clap:Thanks to the whole team, it's great :clap: :clap: :clap:

If you want other specific test, ask me :wink:

Indeed, will note that I am not sure why you would want OctoPi to have 8GB, i would love to hear usage examples.

It would require building a 64bit userspace image.

1 Like

Can your share the fork please so I can see it?
Note it is GPL V3 so you should share it :wink:

I agree that OctoPi / OctoPrint don't NEED 8GB, but I think the issue is more along the lines of if you have an 8GB RPi 4, you currently can't run anything but the 64 bit flavor of the OS.

@Stilfotografen bought one, tried to install OctoPi, and came here when it didn't work. While he may have been the first, I'm pretty sure he won't be the last :grin:

1 Like

I downloaded the beta and it is working fine. I have not tried the Pi camera v2 and I gather that doesn't work yet. Very nice. Thanks!

1 Like

@guysoft the intent was to try to get it to work and once it was functional and reliable to coordinate with you on integrating the changes into your project not maintain a separate one if I remember correctly from discussions with @PrintedWeezl during the initial alpha testing.

1 Like

I don't think this is true. Perhaps you need to update your 32 bit os, but the 8GB version of the RPI 4 should run 32 bit OS too.

Good morning all
I put the error display when launching the 32-bit version.

Having tried the 64-bit version, I find that it perfectly meets the needs of this card.
I tried a B + and I find that 8go brings a lot more than that speed of boot and execution of commands.
I am new to 3D printing.
I wanted to install octoprint and I bought the 8GB because I thought that it could bring more "response" to the application.
I thought the current system could work.
It had just come out and I understand that your site was not talking about it yet.

but if a 64-bit beta version works well for new cards and maybe for some old ones, the constraint will be for developers.
For the future, it will have to maintain the 2 versions.
I have no idea of ​​the work that the team has done on this 64 bit version, but the work works (apart from the camera pi for me).
I am ready to test a working 32-bit version to note the differences.
The new cards will surely be 64-bit compatible and I find it appreciable that the octoprint team tackled the problem so quickly.
It provided a compatible version in record time and of very good quality.

1 Like

Sorry for the late answer

I'm a bit sick right now so it could take a day or two until I get back to the image.

Of course. Sorry I'm new to this. What exactly should I share?
The only thing I changed in your script was to change


to no in this config file.
Should I just fork the octoprint git on github and change it to no?

Ah, ok, I asked because I didn't know what you actually did.
That is a configuration change. No big issue. We might start not ship it anymore since its an old slicer by now. By now I would even prefer to ship sli3r as default instead.

Ok, since cura is super old and @foosel wasn't really for it I am dropping shipping of it in the next build (committed to devel).
I am considering adding slic3r but that is a different issue for now.
Adding a modern slicer such as slic3r might actually give reason for a Pi4 to control OctoPi.

Will note I have no hardware and can't test it though.