🇺🇦 We stand with Ukraine! 🇺🇦

Octoprint on a pi4 8gb

So......perhaps I'm missing something, but is there any compelling reason why it is advantageous to run OctoPrint/OctoPi on an 8GB Pi4?

I have been running it on a pair of Pi3B+'s for almost a year and they work great! Heck, even if you wanted to go with a Pi4 what would an $80, 8GB model do that a $30, 1GB model won't do? I get it could be a bit faster, but we're talking about 3D printing......not exactly a speedy subject! The 3B+ can more than keep up with the gcode spewing required to run a printer.

Sorry if I'm missing it. I have an 8GB, Pi4 and I was planning on building a media box with it, but perhaps I'm missing the REAL value of that model.....

You are not missing anything. The 8GB Pi4 is complete overkill for OctoPrint. Heck, the Pi4 is already complete overkill for OctoPrint. It's non sensical to use a 80$ device when a 35$ device will work just fine.

But just with the Pi0w being horribly undersized, people love to ignore recommendations (and causing people around there work by that) :woman_shrugging:t2:

1 Like

This isn't useful info, but... I got the 8gb Pi4 because I didn't know any better. Had only had my printer a few weeks, and figured even if any extra horsepower of the 8gb couldn't be used by Octoprint, it couldn't hurt right? Who knows what I'll run off that in the future.

... and then I realized the x64 thing. Luckily the beta x64 image was available here and I've been running it flawlessly since. No regrets... for now.

i cant go to the haproxy.cfg
with the command nothing changed

Octopi only uses about 250MB. The 4/8Gb version of the pi were really designed for media servers, desktop replacements, pi laptops etc. Where the extra memory is required for all those extra services, and high demand memory applications. My laptop I use for doing blender 3D renders and animations often uses less than 8gb of available memory, with multiple browsers and notepad open as well.

I finally managed to build a new beta image. I had several issues with the scripts and the os so it took a while.

Let me start with a :warning: warning :warning: :
Beta means that there are and probably will be bugs for some time.

This OctoPi image is based on a 64 bit Raspberry Pi OS (formerly raspbian) lite image which I built a few hours ago.

The Raspberry Pi OS lite image was built with the pi-gen script - the OctoPi image was built with @guysoft s scripts (Octopi and CustomPiOS ) on a Pi 4.

What did I change?

  • I added buster-backports to the apt sources of the base image because of a dependency of the scripts.

What's new in this image?

  • the PiCam is working (incl the HQ cam)
  • latest Debian and Raspberry packages
  • Octoprint 1.4.2

I didn't test the image extensively because I don't have the time right now - also some of you were waiting for a long time for cam support.
If something is wrong with the image let me know.

https://drive.google.com/drive/folders/1m77QXKAoYKxlgORnARI1fxrq3GoA28ne?usp=sharing

28a81f50cb422be8392675433ca34929  OctoPi64-0.18.1-beta.img
561b3894d9156e324d857f52aebb17e9  OctoPi64-0.18.1-beta.zip

Happy testing :slight_smile:
:octopus:

3 Likes

I need to make a new image anyway might as well “live on the edge”. Thank you for the image.

1 Like

@PrintedWeezl Thank you for this and your hard work! I've been catching up on this thread and you are awesome!
I'm new to 3d printing but fairly technical with basic knowledge of non-windows operating systems.
Flashing your 18.1 beta image right now!!

So, please let me know if I can help with testing or anything else to help drive this forward.

Thank you!

1 Like

So I’ve been using it since last night. Wow it flies. It feels so fast and I don’t know if it is a placebo effect but it certainly reboots fast.

How would I know? On 2 occasions while uninstalling plug-ins I lost response and I rebooted. Also when I tried to either restart Octoprint or the system it gave me an error message so I had to manually cut power to reboot.

It threw an error and said look at the logs which I will happily supply if anyone is interested.

But otherwise it printed a small model just fine.

This morning on 2 occasions it lost response and I decided to reboot the WiFi router. The first time when trying to download a log file. Second time because it was still printing just fine. That solved the problem so I can’t say for sure those two earlier reboots were needed.

Mostly everything works. And it works well however the following do not work:

In Dashboard plug-in:
1: CPU use
2: CPU temp
3. Disk space

In resource monitor plug-in:

  1. CPU temp - other stats work

Octolapse:

Could just be a profile issue but for Ender 3 pro I was getting “your printer profile requires an explicit G21 code”. Added it to the gcode no difference. Tried to manually change the setting - no difference.

Changed to Ender 3 profile and it loads something but print never starts. Log says something about temporary name resolution error. Seems like the author may be updating profiles? I could reach the domain on a browser.

I installed Rpi monitor to see temps and it seems to run cooler but I need to do a long 15+ hour print to verify that. The crazy temps (76C) show up only after a long time of being always on.

I am rethinking my whole setup based on this release because I like it so much. And incidentally being my 3rd install I got my plugins right and everything is displaying as I like it. My former install had some issues with multiple plugins showing wrong layer info. This install is perfect.

Edit: So when I work the UI a little too quickly it seems to “crash” however a router reset reveals it is a WiFi or router related issue. It’s actually been very stable with a few quirks which I know will be sorted out in time.

Edit 2: Also this version handles usb/serial connections like a champ. It connects reliably and i’m printing now at 1946 gcodes/sec. No “echo busy” just smooth processing.

Any thoughts of needing to splurge on a new cable or even board to sort out communication issues are now gone.

2 Likes

I just finished a 20+ hour print, worked like a charm, so exciting!

Edit: On a Artillery Sidewinder X1 V4

1 Like

Hi did the mistake to buy a 8gb version of pie. would love to try beta 2 but its not available to download on dropbox can any one share an image.
//Jens

meh
I'm on it

Hello,
I would test this new beta but the link is dead

I'm reuploading it right now :slight_smile:

image

Dropbox is really not very nice

:smiley:
yeah I used a throwaway account for it. might be the reason.
I created a new one - let's see how that works out.
Any suggestions for an other file hoster like dropbox?

Google Drive is a free solution of stockage.
sync.com is another solution

@Maverick_3D @Jens_Backstrom

alright new links online :slight_smile:

if it stops working again I'll try google drive

1 Like

Thank you, the link is OK, I test as soon as I have the file
:clap: :clap: :clap: :clap: :clap: :clap:
Thank you very much for your work

1 Like

Hello, after installation, the camera works, I will do tests this week for stability and operation. thanks again

1 Like