OctoPrint on Lubuntu can't connect to printer

What is the problem?

I wanted to update OctoPrint to 1.8.6 on my old system which was CentOS 7 but it lacked a modern enough Python version, and compiling Python source didn't work. I changed my OS to Lubuntu which could install up-to-date OctoPrint; however, I can no longer connect to my printer. The exact same hardware (control board, USB cable, power supply, etc.) never had a problem with my old setup.

The OctoPrint terminal hangs on the status, "Connecting to port /dev/ttyUSB0, baudrate 115200", which I've confirmed are the correct port and baud. Putty is able to connect to the control board from my OctoPrint server and receives replies to commands.

What did you already try to solve it?

All I've tried has only been able to narrow down the problem, such as using Putty to communicate with the control board. Nothing I've found googling has helped resolve this problem or explain why it's happening.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)
octoprint.log (206.4 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint 1.8.6
Python 3.10.6
CR-10, Control board v4.2.7
TH3D Unified 2.0 firmware (sub-version unknown)
Chrome v109.0.5414.120
Ubuntu 22.04.1 LTS
Linux 5.15.0-58-generic

This may be brltty issue. sudo apt remove brltty

brltty is not installed

Added the user to the dialout group?

That's it! Many thanks.

Now that you mention it, I did have to run putty as root so that makes sense.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.