Octoprint on pi3 upgrade problem


#1

hi people i have a problem on my pi3 , i download the octopi image , after a while it ask me to upgrade from octoprint 1.3.8 to 1.3.10
i run trought the process , all seems to go fine , but after i restart my pi there was no process running ....
in the meanwhile i have upgraded the raspbian image

maybe some problem with the concurrent upgrade? (raspbian and octoprint?) i reflash the image again ,
i make prior the raspbian uograde and after the octoprint ,no luck ....

restart again from scratch .... this time before octopi and after raspbian , it seems all ok , but at some time while i install the software to use a 480x320 display i broke something .....

as you can see from this log (octoprint.log)
https://termbin.com/09bl

it stop logging when the upgrade process ended

same here (plugin_softwareupdate_console.log)
https://termbin.com/wvnd

instead if i lunch the venv (i home in the right manner)
source activate , in the /home/pi/oprint/bin
and after i run octoprint serve

it exit with this error

https://pastebin.com/eHy0Lx09

is the right way to run manually?
where i can investigate more deeply ??

in the final step i will run octoprint on the raspi pi3 with the touch display and put it aside my printer
i have upgraded the pip in the venv ... but it not solves the problem


#2

Please put the first 50-100 lines of /home/pi/oprint/local/lib/python2.7/site-packages/octoprint/settings.py in a termbin/pastebin.


#3

it'snt a text file ....

file /home/pi/oprint/local/lib/python2.7/site-packages/octoprint/settings.py
/home/pi/oprint/local/lib/python2.7/site-packages/octoprint/settings.py: data

if i execute strings , this is the results
https://pastebin.com/R6pxbxKC


#4

That's definitely a problem. It should be text. You have some corruption- probably more than just that file. You should figure out why, but you can force a reinstall of Octoprint:


#5

ok, then this corruption , and the serial exception problem led me to a power problem, i try to change the power supply and reinstall all the stuff
i'll keep update this thread as i have news!!!
thanks for your help


#6

ok, changing the power supply with a 2.4A from rscomponents , i as able to reinstall octopi from scratch , walk through the entire upgrade process without any problem, tomorrow i try to print something and check if i resolve the serial problem too!!!