Octoprint on Raspberry Pi 4B prints, then won't

What is the problem?

The problem is that I get one print complete, no problem. But, when I load another file to print, perhaps even the same model with different Cura 5.4.1 settings, I cannot get the printer to print.

I have the stable version of Octoprint. All basic recommended plugins are up to date.

What did you already try to solve it?

  1. Tried different Cura settings.
  2. Tried letting the printer cool done completely.
  3. Tried renaming the file.
  4. Tried refreshing the browser window, deleting history, alternate browser.
  5. Tried both Mac (12.6.6) and PC (11).
  6. Tried reflashing.
  7. Checked USB cords and ports.

Have you tried running in safe mode?

I have not tried running in safe mode. If I recall correctly, that would limit my ability to monitor the printing online. Anyway, no, haven't tried it. What seems to work, twice in a row, if doing a hard reboot of the raspberry pi.

Did running in safe mode solve the problem?

That would be a negative.

Systeminfo Bundle


browser.user_agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/16.5 Safari/605.1.15
connectivity.connection_check: XXX.XXX.X.X:## (Edited for privacy)
connectivity.connection_ok: True
connectivity.enabled: True
connectivity.online: True
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: True
env.hardware.cores: 4
env.hardware.freq: 1500.0
env.hardware.ram: 3970777088
env.os.bits: 32
env.os.id: linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 4 Model B Rev 1.2
env.plugins.pi_support.octopi_version: 1.0.0
env.plugins.pi_support.octopiuptodate_build: 1.0.0-1.9.2-20230718111854
env.plugins.pi_support.octopiuptodate_build_short: 2023.07.18.111854
env.plugins.pi_support.throttle_check_enabled: True
env.plugins.pi_support.throttle_check_functional: True
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 22.3
env.python.version: 3.9.2
env.python.virtualenv: True
octoprint.last_safe_mode.date: unknown
octoprint.last_safe_mode.reason: unknown
octoprint.safe_mode: False
octoprint.version: 1.9.2
printer.firmware: Marlin V1; Sprinter/grbl mashup for gen6
systeminfo.generated: 2023-08-22T00:52:06Z
systeminfo.generator: zipapi

Is the above what you need?

You can download this in OctoPrint's System Information dialog... no bundle, no support, unless the reason you couldn't retrieve the bundle is your network issues

Additional information about your setup

Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ... as much data as possible

From Mac to Monoprice IIIP over local home network via WiFi, Mac (12.6.6) and PC (11)