OctoPrint only accessible on host machine but not on LAN

What is the problem?
I tired setting up OctoPrint on a laptop with Windows 10 that is running 24/7. I got trough the installation without problems and was able to access OctoPrint using localhost:5000/ and However, when I tried to access OctoPrint using the IP address of the machine ( in my case) I was not able to connect. The laptop also runs OpenMediaVault (NAS-software) which was accessible without problems using its default port 80 at all times. I scanned the laptop for open ports which found the one for OMV but did not find port 5000.

I tried fixing the issue following whathever I found online for a few hours but I could not resolve the issue. Any ideas?

What did you already try to solve it?
-Fresh installation
-Adding new inbound rules to windows firewall and even disabling windows firewall completely
-Choosing a different port for OctoPrint when setting up
-Shutting down OpenMediaVault

Additional information about your network
The host computer is connected to the router via ethernet and is configured to have a static IP (

Sounds like your port is not open on the windows firewall. Could also be a blocked port from an AV.
Here is how I would figure out which one it was.

Test if it is firewall but turning off the firewall. Test... then no matter what the results are turn the FW back on.

Test if it is AV related. Shutdown your AV or set it to bypass, most have a feature like this that will open things up for a period of time. Test and return the AV to active state.

Depending on which one you find is the issue.

  • AV: you will have to learn how your chosen AV allows for you to open ports.

  • Firewall: You can follow this and expect good results. open-port-firewall-windows-10

Another thought is that it might be that the system you are using to connect to the Octoprint instance might also be blocking.. Not likely if it is another windows system but it is not a zero chance.

Good luck and let us know how you make out.

After about one more hour of testing without success, I started looking for another option and decided to use a Raspberry Pi I "salvaged" from another project. Thank you for your help.