Octoprint page grayed out after installing Power Faillure plugin

What is the problem?

Main page is all grayed out - non-clickable. (like clouded)
When the page loads, it briefly has all controls clickable but real fast it turns all grayed-out (faded out / cloudy)

What did you already try to solve it?

  1. Restarted Raspberry Pi
  2. Opened in a different browser (I normaly use Chrome, but tried with Edge)
  3. Tried with Incognito mode
  4. Reinstalled a previous version of Octopi (downgraded from 1.9.0 to 1.8.7 from command line)
  5. Tried from another computer
  6. Tried to uninstall the plugin from the command line, but pip doesn't see it installed.

Have you tried running in safe mode?

No - I can't "click" on any control on the GUI
Can you restart by command line?

Did running in safe mode solve the problem?

See above

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)
Can't reach that page - all grayed out and unclickable


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint version : 1.8.7
OctoPi version : 0.18.0
Running on a Raspberry Pi 3 model B, Rev 1.2
Latest Chrome / Edge version
Tried from Windows 10 Pro and Windows 11 Pro - both up to date with latest Windows Update

Earlier today, I connected to the Web UI of Octoprint and had a notification about an update to the "Octoprint Power Faillure" plugin (hope the name is right). I installed the plugin, after which Octoprint restarted.
Since then, the page loads, and when all the controls are loaded, it turns "cloudy", and all the controls are disabled.

As mentioned, I tried to reinstall a previous version (downgraded) of OctoPrint, but it didn't fix the issue.
I went down the path of trying to uninstall the plugin from the command line, but pip doen't cooperate - I get the message : WARNING: Skipping OctoPrint-PowerFailure as it is not installed
I tried many combination of the plugin name:
pip uninstall Octoprint_PowerFailure
pip uninstall octoprint_powerfailure
pip uninstall octoprint-powerfailure
pip uninstall powerfailure
pip uninstall PowerFailure

At this point, it seems my only hope is to reinstall a backup I had made a couple weeks ago...
Any help would be appreciated!

Also, let me know if you need some logs/files/config that I could fetch from the command line as nothing from the GUI is working.

Hey! I was able to fix my issue!
I didn't know I could run SafeMode by command line.
In case someone stumbles on this topic, here is what I did to fix my issue:

I first connected through ssh to my OctoPrint
I then stopped the octoprint service
$> sudo service octoprint stop
Then, I was able to restart using this command:
$> ~/oprint/bin/octoprint serve --safe
This started OctoPrint in the foreground (in my shell). I could then access the GUI, where I was able to go in the PluginManager and disable the broken plugin.
I then went back to the console, and pressed CTRL-C, which shut down OctoPrint.
I then restarted the service by running this:
$> sudo service octoprint start

So, I ended up being able to restart and recover from this mistake.
I'll flag this issue to the dev!



Hi Oliver_K
Just needed to add a thank you for the solution.

For those having an issue with finding the oprint directory, execute the command from the home/pi directory.

I eventually uninstalled the Power Failure Plugin under safemode, as deactivating it did not stick when I restarted.

Also stumbled upon this today, here's a way that works just in the browser (Chrome here, but similar steps apply in others):

  • Right-click, "Inspect element" anywhere
  • This opens up DevTools and will select a div with class="modal-scrollable"
  • Add "display: none" as element style to the div with class="modal-scrollable"
  • Remove the element class="modal-backdrop in" directly eblow the modal-scrollable.

This effectively removes the gray glasspane disabling the UI and you should be able to remove the plugin the usual way.

Refresh the browser tab when you're done (or let Octoprint's restart do that).

1 Like

Thanks for the details.
I did try to check the source of the page (using the dev tools in Chrome) but wasn't sure which CSS to modify/remove/add.
But I'll keep this somewhere in case I need it for something else :slight_smile:

This didn't work for me.
Grayed out was removed but unable to click anywhere or even scroll.
Please, advise.

Do a forced reload: ctrl+reload button

1 Like

Thanks but didn't work for me

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.