Octoprint & Pi 3b: wifi network not listed

Hi all, so I got a new 3d printer and wanted to setup a pi 3b with octoprint to control it remotely. For some reason however, it is unable to find my 2.4 ghz wifi network. The suno iwlist wlan0 scan did finally list my neighbours networks, but it does not seem to be able to find my network, let alone connect to it.

The pi is fine, as I was using it as a media player and it was able to see my network without issues before.

I downloaded the latest octoprint version, installed it on my micro sd card using etcher (and later the pi image manager), configured it with the correct network settings. When I noticed it wasn't connecting to my network I hooked it to my monitor/keyboard and performed a wlan0 scan (as at that point it wasn't listing any network at all). I read the faq and searched the megathread and internet for similar issues/solutions.

I tried updating the settings through the control panel, but this made no difference. I then updated the network settings (using notepad++) in the supplicant file according to the settings as mentioned in the github section;

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
country=NL # Netherlands

WPA/WPA2 secured


After updating the settings, the wlan0 scan did result in a list of available wifi networks, however these were my neighbours and not my own. Which is still not listed.
I also searched for known issues with my ziggo modem, but wasn't able to find any.

In a final effort I'm tried a different micro sd card, but to no effect.

As said I'm using a raspberry pi 3b v1.2, with a decent power supply and and a 8gb or 16gb mirco sd card.

Has anybody encountered an issue like this before and know the solution for it?

Which channel is your network on?

Bear in mind the antenna on the Pi is pretty small so range wont be great. Although you posted that it can see your neighbor's AP, it's possible his is better placed for your printer (lower, nearer etc.)?

Possibly you might try OctoPi, to reduce the chance of stuffing it up. Definitely try without Ethernet or keyboard/mouse.

Thanks for your replies!

I will check the channel asap! But as for the range of the pi, when I was working with it I was inside my home, about 6 meters from the modem. The distance to my neighbours modem, is substantially larger and includes a couple of thick walls as well. It had no issues with the range before (when used as a media player).

Possibly you might try OctoPi, to reduce the chance of stuffing it up. Definitely try without Ethernet or keyboard/mouse.

This I do not understand, this is about the octopi image incl octoprint. And of course I have tried it without screen/keyboard/mouse. But as it wasn't working I needed to get more info and be able to have a bit more access.

@PrintedWeezl the channel is set to 1 With a bandwith of 20mhz

Would this actually matter?

I updated the channel to 9, with a bandwith of 20/40mhz. But to no effect, I'm still unable to connect it to my wifi

yeah it would matter if you would choose channel 13 for example and a country code which only support 11 channels.

I guess you already checked if any special wifi things are selected on your router?
Like energy saving, special security stuff etc.

Well my router is my modem and has very limited settings. But as far as I can see, everything is set correctly and nothing is out of the ordinary or in energy saving mode.