Octoprint - Pi4 - Hyperpixel Display settings not staying

What is the problem?

Running two Pi4 Octoprint/Octodash servers for my Prusa and Ender. On one I have a generic 4" HDMI display and on the other a Hyperpixel. I set up the Hyperpixel tonight and followed the instructions to install the drivers and rotate the display. The rotate works fine until you restart the Pi. I have searched for this and it seems to be a Pi issue but I am wondering if anyone here runs the same setup and has encountered this problem. I am not a SSH expert by any stretch but can with instructions make file edits and run setups. Any help is appreciated.

What did you already try to solve it?

google the issue and found many similar problems with settings not sticking but not this one

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


How do you rotate the display? (command/config)

From the Hyperpixel github page"

When using ssh --- "DISPLAY=:0.0 hyperpixel4-rotate left". It works and here is the result.

pi@octopi : ~ $ DISPLAY=:0.0 hyperpixel4-rotate left

Rotating display

[sudo] password for pi:

Traceback (most recent call last):

File "", line 3, in

ImportError: No module named screenlayout

Setting matrix: 0 -1 1 1 0 0

/usr/bin/hyperpixel4-rotate: line 10: xinput: command not found

Saving touch settings to /etc/udev/rules.d/98-hyperpixel4-calibration.rules

pi@octopi : ~ $

did you try the /boot/config.txt config?

To rotate your HyperPixel4 you must edit /boot/config.txt and change the following lines:

    Change dtoverlay=hyperpixel4 to dtoverlay=hyperpixel4:rotate
    Change display_rotate=3 to display_rotate=1

This will rotate both the display and the touchscreen input to match.

If you're using a non-touchscreen HyperPixel4 you need only change display_rotate.

Thanks. I found a Chris's basement video and ended up doing the following which worked. Its odd that when select a print from the Octoscreen display ( i am trying it vs Ocdash) it kicks the graphics to the right.


Enable DRM VC4 V3D driver on top of the dispmanx display stack