Octoprint plug-and-play like Octopi but for desktops?


#1

What is the problem?
I was previously running OctoPi on a first generation Raspberry Pi I had lying around and followed a tutorial on installing OctoPi by flashing it to an SD card and it was, for the most part, working okay. I did however encounter an issue where the Pi was actually too slow to keep up with the complexity of some prints, and as such I was ending up with really poor quality prints (on one octopus I was printing it kept pausing momentarily as it printed the outer wall, meaning it ended up looking like the poor thing had acne scars). To counter this, I instead followed the tutorial to install OctoPrint on Raspbian instead which I installed onto an old Dell Studio Hybrid I had sitting around. This has fixed my issues with print quality, however at the top of the tutorial it clearly states it is "not a "Linux for Beginners guide"" which I unfortunately am. I was however able to figure out how to do most of the stuff by some googling and now feel a bit more comfortable using Linux (although it was quite a steep learning curve) but I still don't really know what I'm doing with half of it. Anyway, I have managed to set up a functional OctoPrint build that allows me to print and boots up when I start up the machine, however no matter what I try I seem to be unable to get the webcam services to start with OctoPrint or at boot either. I've followed the tutorial thoroughly and created all the necessary files in the necessary places, but it doesn't start unless I type ./mjpg_streamer -i "./input_uvc.so" -o "./output_http.so" or similar.

Also at some point something changed which I had to alter to allow the SSH to work again (it was working before and then something happened that stopped it, I don't know what but I think I've fixed it) and also as well as this I seem to be unable to use the sudo command without typing in a password at least once beforehand which means that I can't use the OctoPrint UI to restart the OctoPrint services or anything else that requires sudo and as such I have to remote in with an SSH if I want to do any of that.

Long story short, I don't really know what's causing these issues and I'm wondering if there's just a readily packaged version of OctoPrint similar to OctoPi that runs on a desktop machine/x86 architecture that I can just install and have it all work. Does something like this exist? Or will I have to either figure out what the issue is somehow or save up for a Pi 3 B+?
What did you already try to solve it?
Tried checking all the files to ensure they match with the tutorial and they seemed to, tried writing OctoPi image to USB stick and booting from that (it didn't work to the surprise of nobody).
Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)
Latest OctoPrint (1.3.10), Ender 3, Microsoft Lifecam HD-3000, octoprint (1).log (26.9 KB)


#2

Save yourself the money and the grief. Install a new OctoPi image on a Raspberry Pi 3B or 3B+.

The tiny amount of electricity the Pi uses over the period of a year is like $12 versus $200 for an ATX power supply in a PC.