Octoprint randomly stops print, marks as success though

What is the problem?

When I try to print something, Octoprint will start printing just as it is supposed to but then at some point will just end the print.
It says the print finished successfully by marking it green instead of red.
The nozzle will not travel back to its home position, instead it just stops at whatever position it is and stays there also the temperature of nozzle and bed WON'T be set to 0 which makes it a serious thread.

The problem started appearing after updating Octoprint to the latest version a couple of days ago but I also didn't print anything this "big" (~40m Filament) before.

What did you already try to solve it?

  • I re-sliced the gcode file with double checked settings (also changed some in between). While printing that piece, the print stopped even earlier.
  • Rebooted everything of course.
  • Printed a smaller print successfull in the meantime.
  • tried to print from an SD Card but the Anycubic will just crash whenever you select "Print" on the touchscreen to select the file to be printed, that's why I want to try to flash Marlin but before I will try to print from a Windows Laptop hooked up to the printer via USB

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible)

  • Newest Octoprint Version
  • Anycubic i3 Mega with original firmware (planning on flashing clean Marlin)
  • Connected to Raspberry Pi 3 (actively cooled) via USB
  • no hardware mods like different extruder yet

Logs please :slight_smile:

Print finished at 00:42 o'clock on the 16th

octoprint.log.2019-11-16.log (73.0 KB)

Right now it's printing from my windows laptop, I'll keep you updated.
Thanks in advance!

It has finished printing over night and everything worked perfectly fine. I've read that people had problems caused by bad sd cards, might that be the case here as well?