Octoprint reauthenticate issue

What is the problem?

Basically, doing any form of (bigger) action on the instance of octoprint, causes a popup that shows that i need to reauthenticate. No problem. I reauthenticate but it says "Reauthentication failed. Wrong Password?" (The Screenie is german yes i know) And i am 100% Sure that it is the right password. Looked over it at the reconfig of password like 20 times and even wrote it in the google searchbar, and then copied it, to maker ABSOLUTLY sure that it isn't the wrong password. Still gives me that error. Trying this would not always show me that error, only sometimes, but i cant do anything against it. There is something wrong definetly, because in the browser console it gives me the error: "Failed to load resource: the server responded with a status of 403 (FORBIDDEN)" and it links to /api/login:1. All the things i tried you can obviously see down below.
Thanks for any help, im trying to attach as many screenshots and logs as possible :slight_smile:

What did you already try to solve it?

-Reinstalling the instance
-Running in safe mode
-Trying diffrent type of octoprint (Simplyprint)
-Tried older versions
-Looked in Browser logs (This had some results, check dow below.)
-Using without plugins
-Tried disableing all Browser plugins (Adblockers etc.)

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

octoprint-systeminfo-20240606183438.zip (31.7 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint Version: OctoPrint 1.10.1
Octopi Version: OctoPi 1.0.0
Printer: Unmodded (with mods i mean custom firmware) Prusa MK3S+
Firmware: If you mean the printers firmware: 3.13.2
Browser: Chrome, Edge, opera
OS: Idk what to put here either, my pcs os is win11
Server running Octoprint: Raspberry Pi 4B 2018 (dont know how much ram will update if known) connected to a small Display for OctoDash

Multiple other logs and Screenshots i gathered

(The one with Uncaught has nothing to do with octoprint, thats my autofill)
(idk if i should attach any more logs, if yes then just comment that)

To rule this out: You are talking about the frontend password, yes?

Have you looked into the depth of your browser? For auto login they can store the used password.

Uhh idk what you mean really but i mean the pw that not pops up every login but it just opens up and popup for core functions like installing plugins or creating api token it pops up that reauthenticate image. Its not a regular login

As i am trying to understand your message, yes i am talking about the frontend pw and idk what u mean by "For auto login they can store the used password." autlogin plugin is not installed. Im so confused what you are trying to say

I think Ewald was referring to the remember me option and possibly your browser's cached passwords. Does the same thing occur if you open OctoPrint in Chrome's incognito mode?

Ohh yea tried without remember me function and stuff still gives that same issue somehow

trying in icognito rn

it does work but only for a certain amount of time

hmmm...I wonder if the issue is related to the error ValueError: unsupported format character 'Z' (0x5a) at index 93. That was something that was recently found to be related to German translation. If you switch to English by appending ?l10n=en to the end of the url does the same thing happen?

the other option would be to disable the reauthentication stuff for now. You'd have to add it manually to config.yaml via SSH and restart OctoPrint.


  # Default timeout after which to require reauthentication by a user for dangerous changes, in minutes.
  # Defaults to 5 minutes. Set to 0 to disable reauthentication requirements (SECURITY IMPACT!).
  defaultReauthenticationTimeout: 0

Thanks for the info! Forcing to englisch didnt work, im trying to disable reauthentication rn. And i know that it could impact my security but im just going to try for now until it is fixed cause that problem is really annoying.

@foosel may need to get your input on this one. I personally haven't had any issues with reauthentication.

So umm there is a good thing and a bad thing. Good thing: I found config.yaml in ~/.octoprint but when I sudo nano config.yaml, I could not find acess control section and anything corresponding with it.

For now im just going to stick using incognito tabs

oh yea and sorry for the late replies, school is kind of a problem sometimes

No need for sudo, and accessControl isn't there by default, you have to add it. If you copy paste what I put above to the end of the file and restart OctoPrint it should work fine. The only thing that is important is the spacing for the second line, you can leave out the lines that start with #. Like this...

  defaultReauthenticationTimeout: 0

I should add explicitly, do not use sudo to edit the configuration file. You can mess up the permissions and then OctoPrint will not be able to write to the file.

I have no clue here either. Haven't run into any issues at all, haven't heard of anything like that from anyone else either.

In general, that it will require you to reauthenticate after around 5min is normal. That it doesn't accept the password is not normal. What is also not normal is that "bootstrap-autofill-overlay.js" error in your browser logs, that is not part of OctoPrint, but you already mentioned this is your password manager or something like that. I strongly recommend you try a browser profile without any browser extensions to rule out one of your extensions causing this. Or try a different browser altogether.

I did (mentioned this already in the first post) with the browser.

I didnt saved the config with sudo thats good thx for mentioning!

I think like this maybe?
Imma save it and update you if it fixed anything.