Octoprint reboots in safe mode

What is the problem?

Octoprint reboots in safe mode when trying to update octoprint. it says: Problem during last startup

What did you already try to solve it?

I tried looking at octoprint.log I can't disable third party plugins because it is in safe mode

Have you tried running in safe mode?

It reboots in safe mode

Did running in safe mode solve the problem?

No, the problem is that it reboots in safe mode

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

octoprint-systeminfo-20220201151000.zip (29.5 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

1.7.3, Ender 3 with SKR Mini E3 v3.0, Marlin(Not klipper, nothing special configured in marlin for octoprint), Chrome, Windows 10, Octoprint running on old acer laptop, on ubuntu server.

octoprint (4).log (114.2 KB)

Hello Calin,

octoprint.log contains

2022-02-01 14:35:30,553 - octoprint.startup - INFO - Starting in SAFE MODE. Third party plugins will be disabled!
2022-02-01 14:35:30,553 - octoprint.startup - INFO - Reason for safe mode: problem during last startup

and just above it is:

  File "/usr/lib/python3.8/http/server.py", line 138, in server_bind
  File "/usr/lib/python3.8/socketserver.py", line 466, in server_bind
OSError: [Errno 98] Address already in use

The log contains errors from octoeverywhere plugin and then there is this warning:

octoprint.server.api.system - WARNING - Command for core:restart failed with return code 1:
! STDERR: sudo: a terminal is required to read the password; either use the -S option to read from standard input or configure an askpass helper

When you ssh into the system and do a sudo systemctl restart octoprint, does it give you errors?
Besides restart there are status and start, stop - can you do those commands smoothly or are there errors?

How did you install OctoPrint?

I may have got it fixed, I unistalled octoeverywhere, still did't work, then I turned off my raspberry pi(Not running octoprint, running raspian) and it worked! I still don't know exacly what caused it but it works now, I think the raspberry pi maybe had the same address?
I'm not an expert, so I appreciate your help, Thank you!
By the way, I am running octoprint on a old acer computer, and installed it using this guide from a youtube video: Google Doc Guide
Hopefully it works for a while now, Thank you for your help!

Glad you got it working again. I noticed you had OctoPrint running as a different user than pi so it couldn't be a standard install, that's why I asked.

Just for the record: the 'official' installation guide on Linux is at
Setting up OctoPrint on a Raspberry Pi running Raspbian or Raspberry Pi OS

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.